PC won't recognize my Olympus C55-zoom camera

  rmcqua 10:00 05 Mar 2006

I originally posted this in "Digital" but with hindsight, maybe it should have been here in "Helproom":

I have had an Olympus Camedia C55 Zoom for about 2 months. The "Olympus Master" software never worked on this PC, but that didn't bother me because I used to transfer images using the Windows camera wizard (I am running XP Pro).
All worked fine until recently and now, when I plug the camera into ANY of the PC's 6 USB ports, it isn't recognised. I select "transfer to PC" from the camera's menu, the camera's LEDs start to flash, but the image transfer wizard does not initiate.
All other USB devices on the PC work fine, ragrdless of which USB port they are connected to.
The camera works fine on my son's PC, running XP Home.
I have checked the USB settings in BIOS and they appear to be in order.
With the camera connected and switched ON, it does not show in control panel > cameras and scanners, neither does it show up anywhere in My computer.
Any ideas?

  alB 10:34 05 Mar 2006
  [email protected] 10:37 05 Mar 2006

Hi. Sounds like the camera or the lead! Can you try it on another PC? If not, then maybe it's a driver issue. Usually you have to run the disc first then plug in the hardware for the PC to recognise but sometimes it's the opposite which works. Uninstall everything related to the camera, including the driver, and reboot. Plug in the camera and see if the new hardware wizard is prompted. If not, then suspect the lead and/or the camera. If yes, follow the wizard and insert the disc - or - go online and let windwos find the driver. Good luck.

  jimv7 11:31 05 Mar 2006

Are the camera batteries fully charged, with my olympus installing new batteries when the computer will not see the camera works.

  jack 11:41 05 Mar 2006

IMHO this problem when it comes up[and it does frequently either software or camera not performing]
The answer is to obtain a Media Card reader
Simple cheap, saves on battery and camera wear and tear.

  Al94 12:43 05 Mar 2006

Must say I agree with jack, I always slip the card into a reader and downloads so quickly. They are so cheap now, for example click here

  rmcqua 13:41 05 Mar 2006

Thanks folks.
[email protected]:
yes it works fine with my son's PC. There aren't any specific drivers available for this model (at leats none that I can find) - according to Olympus it should be (and used to be) OK with the Win XP drivers.
That's a good point,. It has been sitting around for a few weeks; I'll try topping them up
jack & Al94:
If this fails, then a card reader will definitely be my next step - they're certainly not expensive!

  rmcqua 14:18 05 Mar 2006

OK, this gets stranger.
Tried new batteries, fully charged NiMH, no difference.
Instead of selecting "USB > PC" transfer from the camera menu options, I tried "USB > Printer". this immediately initiated the programmes option asking which programmes I wanted to use for this function, I selected photo transfer wizard, the PC recognized the camera (auto listed it in scanners and cameras) and transferred the photos fine.
Removed the camera and then re-connected it and same again - not recognized!

  Al94 15:36 05 Mar 2006

This might be a long shot but have you installed Realplayer recently or is it on your system? Heard of a case a couple of years ago where ununstalling Realplayer allowed an Olympus mju 300 to be seen by a PC again. Failing that, sounds very much like a driver issue.

  Al94 15:43 05 Mar 2006

Have you tried a system restore back to a date when it was working?

  Diemmess 15:56 05 Mar 2006

Could still be a faulty USB cable, one that has a broken or inadequate conductor occasionally making or breaking contact.

I suppose you are quite sure the camera isn't popping up with a different drive number?

Like you I prefer to cut everything from the camera and paste to a temporary folder.
The camera is disconnected and then I can quickly view the lot, deleting what is unwanted and saving (named) the best.

The camera's tummy is unviolated, the card remains where it should be, all at the price of a few seconds of battery to download.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)