PC wont recognise ethernet cables since ISP outage

  filu63 16:04 25 Sep 2017
Locked
Answered

My son's PC (which does not have a wireless adapter) has previously used TP link to connect to internet. Since TalkTalk had an outage in our area, he can no longer connect via TP link or by direct ethernet cable from router.

Does this sound like the ethernet port is fried? If so what can I do about it? He is suggesting a USB WiFi adapter, but I don't want to buy if it won't work without the pc having wifi capability - I'd rather fix the issue.

I should add that, although somewhat of a Luddite, I've tried the basic options of turning everything off/on again and trying different cables and ports with router.

Thanks in advance.

  Jollyjohn 16:24 25 Sep 2017

One of these should work - click here - make sure you get this one and not a 5GHz dongle. They are pretty much plug in and go. Enter wifi key and you should be connected.

I am assuming other devices in the house can connect to the internet.

  wee eddie 20:05 25 Sep 2017

I am trying to imagine what an ISP might have done, or not done, to cause the failure of an Ethernet Port.

Assuming that the Router is still doing it's bit. The problem is, more likely, within his PC

  filu63 07:51 26 Sep 2017

Thanks Jollyjohn, yes all other devices work fine and I've tried other ports/cables. It's prob the PC itself.

  Fruit Bat /\0/\ 11:53 26 Sep 2017
Answer
  1. untick the answer from wee eddie until your problem is solved otherwise people will stop looking at the thread and you will not get noices when someone repies.

  2. Have a look in device manager at the network adaptor is there an exclamation mark against it - try uninstalling and reinstalling the network card.

Have you tired connecting to the router by typing 192.168.1.1 into your browser address bar?

  filu63 13:27 26 Sep 2017

Thanks, Wee eddie...despite my claim to be a Luddite, even I didn't think the ISP had 'caused' the problem...just that his pc was connected when it went down - then hasn't recognised any ethernet cable since. I thought it might have been a network adapter or IP address issue, but Jollyjohn has come up with a fix :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Pokémon Let's Go, Pikachu! and Eevee! review

Best Black Friday deals for designers and artists 2018

How to use Siri Shortcuts

Les meilleurs SSD