PC wont boot after bios update attempt. HELP

  stefanopruc 19:55 27 Sep 2018

Guys, I have a very specific problem here...

My former PC specs: H61M-P23 (B3) Motherboard Intel Pentium Dual Core G620 2.6ghz AMD R7 360 2GB 8GB DDR3 RAM 1TB HDD 550W power supply

I recently made a decision to upgrade my CPU from the G620 to an I7 3770 which i bought used from a trusted seller. I also recently (about 6 months ago) upgraded my GPU from a Radeon HD6670 because it died,and for that i updated my BIOS to version 19.0 which wasn't the latest one for the motherboard, but was ok enough for the new GPU, since it just needed any update in order for the BIOS to recognize the GPU.

Now, with the I7 i bought i also bought a new CPU cooler. It's made by LC power and it can fit inside my case just fine. So since i already updated my BIOS relatively recently, I figured i could just pop the old CPU out and pop the I7 out. Nope. Didn't work. The PC went into that boot loop until you turn off the power supply. So I popped the old CPU back in and booted the computer, went to the msi website for my motherboard and attempted to download the 19.1 version of BIOS but the link didn't work, it simply said "File not found." So i downloaded the 19.2 version which was the latest one and tried to install it, but there are no tutorials for the 1 .exe file i get from the zip folder, so i went freestyle. Tried everything and got to the point where i set up the m-flash thingy in the BIOS. And that is the last time my computer fully booted. I restarted my PC and some things happened and then we got to this point where the PC doesn't boot and i cant do anything about it. I reset the CMOS a thousand times, my old CPU gets rejected by the BIOS or something but it just doesn't boot up. The only thing that happens is when reset the CMOS and i put the I7 in with the GPU and everything. It boots up to a black screen that lists me my CPU, my RAM and the USB devices even tho it always says: 0KBDS 0MICES 0MASS 1HUBs. It also says that everything has been set to default values, then gives me a choice to press F1 to RUN SETUP or press F2 to CONTINUE I plugged my keyboard in the purple keyboard port beforehand so i can use it and choose one of those things, but regardless what i do or choose it always starts a countdown from 5 and then everything freezes once the countdown has come to a 0. I tried everything, every way to start the pc, gpu in or gpu out, everything. It doesnt even boot unless the circumstances are like above:i7 in and gpu in,keyboard in,anything else can be plugged in but it doesnt get recognized by the BIOS anyways. I've run out of ideas I cant boot it idk what to do. I can't simply "update the bios" since i cant even boot the god damn thing.

Please if you know what to do, help. If nothing else works i might as well just take it to a pc service store, to see if they can do anything about it.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Samsung Galaxy Book 2: Release date, price and specs

This First Man soundtrack vinyl cover art is exquisitely composed

How to watch Apple’s October 2018 iPad launch

Meilleurs VPN (2018)