PC refused to power on, now its decided to work??

  square eyes 13:53 16 May 2006

Hi all,

A nasty experience last night, went to switch on pc and NOTHING!
Its in a MESH tower with a push-in button (with a click) to power it. I tried for several hours and must have pushed the button 200 times or more. This is because in the past when i have left it off for a few days i go to switch it on and only on the 2nd or 3rd push it works. Last night i was hoping the next "push" would fire it up, anyway i gave up.
Today, just before i started making phone calls, hassel friends for their internet, i tried it quickly and ((BAM))>> it worked first time!!

This i hope is the clue as to what is wrong with it. When it didn't power on there was still a green light on the mobo inside tower.

My personal thought is the switch that is faulty or is there something else responsible for powering on?

This im sure is insignificant, the last thing i did to it yesterday was in power options i set pc to "hibernate after 2 hours" but manualy switched off before the time came, ive now set it back to "never" just in case.

At least i can relax a bit now as the mobo is still in the living and not dead as i thought last night.

Any help or info much obliged, i dont want a repeat of that so i need to do something.


  alan227 14:09 16 May 2006

Have you tried disconnecting the power switch connector and using a screwdriver to fire up your computer, you must remove the screwdriver as soon as it starts up.
This will show if it is the start button or not.

  square eyes 14:20 16 May 2006

Thanks alan227,

Was just reading about that before i read yours, No i didnt try that, im nervous about switching it off at the moment to try it.
If it does it again i will try the screwdriver test, the lead that comes directly from front switch onto mobo?

  johndrew 14:24 16 May 2006

You could also check the switch by disconnecting the plug from the motherboard and using a meter (continuity/resistance) to check the switch.

Failing that move the connector on the motherboard and ensure you have a `clean` connection before the next startup. You could also ensure the wires are connected to the switch properly.

Probably safer than shorting the pins inside a `live` computer (sorry alan227) which, if you slip could do some real damage.

  square eyes 14:35 16 May 2006

thanks johndrew

I checked the connections and moved them slightly last night but made no difference.

Good idea about testing continuity of the switch but would probably show no faults as it is now working.
Dont worry about me trying the screwdriver, i have a steady hand, or maybe i use a short piece of wire.

As i say i need the pc on for a while, so next time it does this, i will try the reset (never did that) short the two pins or test the switch, but it DOES sound like a the switch could be bad?

Apparantly MESH supply them for a couple of quid

  square eyes 14:42 16 May 2006


I had a brain-wave, i wanted to check the switch without switching off, so i went into power options and selected "when press power button on tower: ask me what to do"
The switch now brings up the closedown screen (black&white desktop) so i just cancelled, this has worked for 20/20 times, sounds strange, abit of dirt in the switch? temperature change?

  DieSse 15:00 16 May 2006

The green light on the motherboard is probably there all the time when the mains power is connected.

I've never seen a switch fail (though I suppose it's possible) - they're so simple it would be very difficult for one to fail IMO.

Most problems of this ilk are PSU problems.

  square eyes 15:45 16 May 2006

i agree, switches are simple, why would it fail, then suddenly work?

Is there a component on the mobo that is responsible for powering?

Now you've said that, it could still be a prob with mobo which isnt good.

Yes the green light is on all the time the main power switch at the back is on, simply stating the fact.

Well next time it happens and shorting the pins doesnt work, then its a new mobo time i guess

  woodchip 15:57 16 May 2006

The Bios does the firing up after you press the switch. Then it changes to the OS. Plus ATX work different to the old AT system, when on the AT 240 volts was switched by the power button. Where with at ATX there is always some power at the motherboard, while the Mains plug is left in the socket and switched on. ATX does not have those volts on the board or at the power button it does not, or should not go any further than the PSU

  square eyes 16:22 16 May 2006

Thanks for your comments, a mystery dont you think, not a nice thought that it will happen again at an inconvenient time.

I'll let you know,

p.s. there was a build-up of felt where the switch is as there seems to be a vent there, just possible it was a bit of muck found its way into the switch.

  rodriguez 17:02 16 May 2006

I had this problem with a computer and it was the motherboard's fault. Usually it would start up 1st time but sometimes I'd press it 2 or 3 times before it fired up or I'd just jab the button. Anyway, when I upgraded the motherboard and CPU and the problem disappeared. This might not be exactly what's wrong with yours but it's an idea. The other component that could be at fault is the power supply.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Brilliant (and Weird) World Cup 2018 Art and Design Projects

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?