PC drivers don't load until 2 mins after startup

  AdaptionzNeon 23:15 07 May 2018
Locked

Hello, I had around 3 computers in the past and until 2 months ago, this problem has started. Every time I shut down my computer and start it up/restart most things run including my discord, steam and others, But my drivers don't load up i.e NVIDIA Graphics, Wacom Tablet Drivers, Corsair Utility Engine, Realtek HD Audio Drivers. It also doesn't recognise my keyboard, mouse, my three monitors, microphone and tablet which is usually quite weird. But after 2 minutes of my PC starting up, all the drivers start to load and it even recognises the peripherals. So I tried reinstalling all the drivers and reinstalling my OS including cleaning my drives and it didn't work and I really don't want to think its my cpu, mobo or graphics card since they're all expensive and I don't make much money so it would be hard to buy new parts.

P.S The middle monitor is the one that works while the left and right are turned off but they turn on when the drivers turn on

Mobo: Asus Prime Z370-P

Graphics Card: MSI Geforce GTX 1080

CPU: Intel I5-8600k

RAM: Teamgroup Vulcan 8GB

Power Supply: bequiet! Straight Power 10 750 watt

SSD 1: Samsung SSD 840 Series

SSD 2: Samsung SSD 850 EVO M.2 500GB

Hard Drive: WD Ext HDD 1021 USB Device

Keyboard: Corsair Strafe RGB

Mouse: Corsair Scimitar Pro RGB

Monitors: 3x AOG G2460PF 144hz 1MS

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Officially Launches In The UK

Inside the concept art behind Nicolas Cage's most bizarre film, Mandy

MacBook Air 2018 review

Comment supprimer un compte Facebook ?