Pc downloading KB974417 constantly.

  SB23 15:58 14 May 2010

For the past few days my pc has been downloading KB974417 and trying to install, but as soon as it does this the yellow shield returns with the same update, and the process starts all over again. I've tried rebooting but this has no effect, and now I've turned off updates completely as its getting annoying.

Am running Xp Sp3, any ideas?



  T0SH 16:06 14 May 2010

If you use the custom install mode in windows updates you can easily hide the problem update

Cheers HC

  compumac 16:14 14 May 2010

Control Panel/Add Remove programmes including Microsft updates - Does KB974417 display as being already installed?

  SB23 16:59 14 May 2010

Just checked and no it isn't there.

  SB23 17:03 14 May 2010

Although I've just checked my update history with MS and it states, (with a green tick) that it installed ok 3 times on 13/05/10.

Whats going on?

  northumbria61 17:15 14 May 2010

It appears that you are not alone with this problem and it appears that it may be caused by update KB976569 - the one you refer to (KB974417) needs to be installed before that one (KB976569)

See the post on this LINK by "Brainstormer"

click here

  SB23 19:17 14 May 2010

Problem with that is KB976569 isn't already installed.

  woodchip 20:23 14 May 2010

Set Updates to Manual, it will not do it no more, only when you choose to update

  Terry Brown 20:46 14 May 2010

Down load and run BELARC, this will show you a list of all installed updates (among other things), click on the update KB974417 (by the star) and it will take you to the Microsoft page for that update, where you will get more advise.

  Confab 20:49 14 May 2010

Had the same issue as you.

This is what I did but I’ve no idea why it worked
Ran CCleaner to clear any tempfiles.

Searched for any files named KB974417 on my harddrive and deleted them.

Downloaded net clean tool from click here and cleaned up Net Framework 1.1 and Net Framework 2.0.

Went to add remove programs and clicked on uninstall Net Framework 3.5 SP1.

After a while it gave me the option to repair so I said yes. Then it said something about needing to download files so I again said yes.

Rebooted and all worked OK apart from Microsoft Office 2007 which for some reason I had to repair.

I have no idea why the above worked and would suggest that you back up before trying.

Good luck

  SB23 14:04 15 May 2010

Afternoon all.

As this issue would appear to involve the .NET Framework, I tried to repair via add/remove, but its not having any of it. It won't let me uninstall either, so any idea what my next course of action would be?



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?