Password not being accepted in new router

  kwil2 15:38 15 Sep 2013

Hi... I'm running Win7 Home Premium (64-bit) with an Edimax wireless card. All drivers are up to date. Here's the problem: I've been TalkTalk customer for a few years now without any major snags. Recently, because of a speed issue with my current router (Huawei 523a), TalkTalk sent me a new one - a D-Link 2780.

When I connected the new router, it was recognised fine. Next stage is to enter the password (on a sticker at rear of router). However, the password came up as incorrect/try again. I triple-checked the password and tried the above a number of times with the same result. I therefore concluded the router was faulty and returned it for a replacement.

The replacement arrived - this time, a Huawei 533, labelled by TT as 'premium' and the router used by them for their YouView TV service.

I went through the same process as above and found entering the password in this router also met the same fate!!

Consequently, I've had to reconnect my original router which is why I'm able to post this!

So, after the second failure I've begun to suspect there might be something within Win7 that needs tweaking though why my current router still works perfectly seems to suggest that's not the case and that the problem lies with the new routers.

That one router should 'fail' in this way might be acceptable but two different routers and two different brands??? Also, please note I've no other wireless connections to any other devices that may be conflicting.

Anyone have any idea what's wrong or what, if anything, I'm doing wrong?

Many thanks

  100andthirty 15:53 15 Sep 2013

I had a similar problem with a mifi device. In the end I connected using a cable (ethernet for you, mine was via USB - a detail but not really relevant!).

If you connect by ethernet, you should be able to conect to the router and use its admin password to access the settings. Then you can check whether the wifi password is the same as is printed on the label! If not, then you can change it to something you recognise.

By the way, just to double check, I hope you've been trying to connect to you new router over wifi, i hope you entered the wifi passwordn and not the admin password of your TT account password, something that is easy to do, even for the most experienced person

  rickf 15:54 15 Sep 2013

Maybe try connecting using an Ethernet cable in the first place and take it from there to a wireless connection?

  Mr Mistoffelees 15:58 15 Sep 2013

If you connect to the router, with an ethernet cable, you will be able to see and verify the preset password and change it if you want to.

  rdave13 16:14 15 Sep 2013

Remember you need to input your ISP's 'name and password' you were given and you also need to input the security (wpa2?) key for wi-fi. They're on different sections within the router to input.

  spuds 16:27 15 Sep 2013

For what its worth, I use a TalkTalk supplied Huawei EchoLife 520b router, which connected both by cable and wireless. For some unknown reason the wifi part suddenly stopped working on a laptop, due apparently to an unknown password problem. I have never been able to make a reconnection, even after seeking advice on this forum, trying various methods?.

I have just been doing a few review checks (Amazon) on the two 'new' supplied by TalkTalk routers mentioned. The D-Link 2780 seems to have a low scoring due to not being able to use virtual private network?.

  kwil2 01:21 16 Sep 2013

Hi all...Many thanks for taking time to reply. I'd already tried the Ethernet route before but was getting no connection at all.. As Murphy's Law would have it, I tried again a few minutes ago got through to this site. But when I tried submitting this reply...nothing happened...Speed too slow, I wonder? So after a few more rebooting of computer etc here I am again! Anyhow,I managed to check the Huawei 533 router via 'admin/admin' and found at the 'Connection' summary that the password does actually match that on the router. So why the hell didn't it work? Now: I've never had to do this before so forgive my ignorance: 1. Am I right in thinking I can change the password at the 'Connection' area to something else (see 100andthirty's comment above) and that will be OK within the router? 2. Whatever 'new' password I choose: do I have to make this the same number of characters as the router's original password which is also expressed in CAPITALS (letters and numbers)?? Or can it be anything I want? 3. Other than sucking it and seeing, is there any way I can be sure the new password won't be refused as the original one? Would appreciate your continued help.

  kwil2 01:23 16 Sep 2013

Forgot to mention...all the lights on the router are green and all SHOULD be working...Just a little anxious about going the Ethernet route, then having the 'new' password hang on me like the first time I tried to reach the Forum and post....grrrr!

  spuds 09:44 16 Sep 2013


Have you tried TalkTalk technical support, or the TalkTalk forum. When I was having my problems, this was suggested by this forum member's. I found the person I contacted in technical support, 'talked' me through a number of things, making quite a number of adjustments. It took about 20/30 minutes, and all was well, until the problem returned later. In that time I had forgotten what we had done to make the connection, so gave up.

  kwil2 14:02 16 Sep 2013

Hi spuds... Have been a Forum member for some time and it is a useful resource. However, it's clear the poor people having to deal with TT's problems are being swamped with complaints not of their making. In short, they do their best to help deflect from the core problem...TT's systems and connections to exchanges. When I had the first router sent, the D-Link, the Forum people proved useless. As for Technical Support...well, given the fact everything was fine with my 'old' router and the two router TT sent me are giving difficulty, then far as I'm concerned it's TT who need the Technical Support! While commendable they took time to solve your issue, the fact the issue returned speaks volumes for TT's 'systems' The fact I've now established the Huawei 533's password correctly matches that on the router's back sticker should mean the router should work...yes? I'm a bit wary about allowing them to send me yet another router, since I can't be certain that won't have the same issue. Meantime, I've managed to get online wired via the 533...but that could be another 'fluke'..Hope I can post this without it hanging again!

  Press Man 15:08 16 Sep 2013

You've probally got all of this , but just incase here it is again click here and click here hope this helps.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?