Optical drives on IDE 2 not working

  Indigo 1 17:13 25 May 2004

Sorry for starting a new thread on this subject but I felt that I might get a better response if I re-worded the title..

Original thread click here

I have now tried a new IDE cable and also tried IDE 3 and 4 ports but still getting nowhere.

BIOS recognises both drives and Device Manager too but there are still yellow exclamation marks by each one in D M and still not showing up in My Computer.

Any ideas please respond on either thread.

  Satmansq 17:42 25 May 2004

I had a similar problem which was related to recording software but pretty obvious as i had just loaded the software.

  hugh-265156 17:45 25 May 2004

try clicking properties/driver and select roll back driver in device manager.

try also uninstalling both drivers via device manager and restart the computer.

windows should find them again and install the drivers again automatically.

  hugh-265156 17:47 25 May 2004

or try system restore back to a time all was well.

  Indigo 1 18:18 25 May 2004

As I said in the other thread, Sytem Restore makes no difference.

Will try to uninstall drivers if I can figure out which ones they are.

Strangely no new software was installed prior to this fault occurring so I can't pin it on that.

The only thing I did notice was, when I got home from work the PC had re-booted and that's when I first noticed the problem, it was fine untill then.

  Gaz 25 18:21 25 May 2004

Ummm, IDE chip problem on board?

Could be BIOS settings, what bout jumper settings?

Checked all them, then its a faulty mobo.

  Indigo 1 18:41 25 May 2004

Ok just uninstalled drivers for both devices and re-booted.

Windoze found both devices and installed them but didn ot confirm they were "Ready for Use", I still have yellow exclamation mark by each device.

Proerties for each device in Device Manager gives the following message, "Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)" what is error code 41 ?

The strange thing is that Device Manager doesn't indicate a problem with IDE controller.

Gaz 25

Bios settings look fine (not changed) and no jumpers to set.

Will try to swap IDE 1 and IDE 2 connectors to see what happens.

  Indigo 1 18:44 25 May 2004

Anyone know of a way to test IDE chip from within Windoze or BIOS ?

Is there a way to find out what may have caused the PC to re-boot while unnatteded and if this might be the cause of the problem or if the problem caused the PC to re-boot ?

  €dstowe 18:47 25 May 2004
  Indigo 1 18:52 25 May 2004

That's great thanx, I will try that ASAP.

This forum never ceases to amaze me, it would have taken me a Month of Sundays to find that thread.

Cheers. ;0)

  Indigo 1 19:25 25 May 2004

Thanx it worked !

I tried the Doug Knox download fix first (as it looked easier) but it didn't work so I went for the registry hack and it work a treat.

I am all smiles now :0)

I shall remember you in my will cheers M8

I am such a happy bunny I could kiss you all.... :0)

I'm gonna tick the box ..

I'm gonna tick the box...

I'm gonna tick the box...

Here goes......

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?