Old CDs -playing

  COLFY 13:00 10 Dec 2006

Have just installed the new Sony DVD player
AW-G170A. This replaced a dead CD player. Old CD packages such as 'Learn to Speak French' will not load and a message I get also with other old packages is ' Floating Point - Divide by zero '. Does anybody know what this means? I reckon the CDs are probably too old and are 16 bit and are not supported. Thanks for any view.


  Fruit Bat /\0/\ 13:53 10 Dec 2006

There is no reason why 16bit programs will not run,
I run som old 8bit programs ok.

Try clenng the CDs.

Also to get rid of the error messages try a repair
Repair XP by replacing corrupt files

sfc /scannow

in the run box, press enter and let system file checker find and replace missing / corrupt file in windows and explorer.This will take awhile to complete and you may be asked for the CD to be in the drive if windows is not preinstalled on the hard drive.

sfc /scannow problems
click here

  Stuartli 15:21 10 Dec 2006

I have the same Sony DVD rewriter - it plays 15-year-old and older audio CDs OK (just checked as I normally use a DVD-ROM drive for audio CDs, software installation etc).

Could be that Uninstalling it from Device Manager and rebooting may help and/or ticking the Use Error Control box under the Analogue/Digital choice for CDs.

  COLFY 15:23 10 Dec 2006

Dear Fruit Bat,
Thanks for help but still no joy. CDs were very clean,and as new - ran System File Checker in full - loaded 'Learn to Speak French' and icons appeared after message that all installed, but trying to run it get box : Application Error /
integer divide by 0.
On the CD carton it states that CD runs on 3.1 and 95 but it certainly don't like my XP Prof SP2 !
Thanks anyway.

  rodriguez 15:27 10 Dec 2006

You could try opening the CD in My Computer so that you can see the files. Then find the main .EXE it runs, right click it and select Properties. Then go to the Compatibilty tab and set it run in Compatibility Mode for Windows 95.

  Z1100 15:43 10 Dec 2006

The PC is just telling you that the MPEG software you are using is trying to divide another checksum by Zero. Try using another Multi Media software application first.


  COLFY 17:19 10 Dec 2006

Thank you,everybody, for your kindness in sending advice. I have tried all suggestions but still nothing works so I think the 'Learn to Speak French' course will have to go to a charity shop where someone may find a use for it.
If any of you nice people want it let me know and I will post it to you.

Thanks for all of your help, anyway.


  Stuartli 17:32 10 Dec 2006

Try installing the K-Lite basic codecs pack from:

click here

I've an idea it may be a missing or corrupt codec.

  Fruit Bat /\0/\ 18:00 10 Dec 2006
  COLFY 19:32 10 Dec 2006

Thankyou to Fruit Bat and Stuartli for the additional suggestions. I have found the K-Lite site and will get back to it and I downloaded the Windows 'Run Older Programs' info but have no success at the moment.
I have had enough today of mucking about with this problem and am off to the claret .
I am closing for today and will not be able to get back until Tuesday so I wish all of you farewell and I send my heartfelt thanks for your efforts.
Computers do annoy, at least one can shoot a sick horse.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?