O2 Broadband Dongle - Connecting with Linux O/S

  seftonsun 10:45 26 Jun 2009

I have bought a Pay as you Go O2 USB Mobile Broadband dongle (Huawei E160). I have an Acer AspireOne Netbook with 512 mb Ram and 120Gb HDD. It is running Linpus™ Linux® Lite version. The browser is Firefox.

I have got (I think) the latest updates installed for Linux that I was told should allow an idiot like me to just connect. I'm obviously a bigger idiot than people think!! What I am struggling with is getting the dongle to connect so that I can get online. I have tried going through connection manager, Mobile Partners and 3G Connection Manager in the Connect Menu, but all to no avail. The light on the dongle goes solid blue/turquoise but I just cannot get it to open a browser window,etc. To be honest I do not really know how I got the light to come on (but see below)! I can see the dongle in connection manager, but when I highlight it it does not give me the option (as it does with my normal WiFi) to connect. The connection option just stays pale grey in the background. In fact I'm not sure if I have even installed the dongle correctly or if you need to install it? Just to note I have tried booting up with and without the modem connected. It doesn't make any difference to my problem as far as I can see. Also the modem flashes green when first connecting and then flashes blue when (I assume) it is recognised and a signal is available?

An idiots guide to what I should be doing and how to do it will be very much appreciated. As I do not have always have the Netbook with me I may have trouble providing specific answers to any question immediately. I will give it a go though if anyone can help, otherwise the answers will have till wait till I have with me.

For more information after more messing in Mobile Partner screen in the bottom left hand corner it shows either 3 or 4 vertical bars for the signal strength (BTW 2 of us are on O2 and have no connection or signal issues). From the bars reading right across the bottom it then says "WCDMA" and then "O2 - UK". Then along the botton towards the centre of the screen there is a little PC screen icon with a little red circle/white cross on the bottom left hand corner of it.

If I click on connect against the Profile Name O2 (the name I assigned to this mobile modem) a box pops up saying "connecting...". After a few seconds this box is replaced by another that says "Error" and with two options of retry or cancel, whilst in the top left corner of the box are pictures of two little screens joine by a line with an icon of what looks like a mobile phone in the middle of the connecting line.

Would the problem be the number that is being dialled? In Mobile Partner Tools/options the Access Number is shown as *99#, is that correct? The other details areunder APN static is checked and dynamic unchecked . Whilst in Authentication Protocol Settings CHAP is checked and PAP is not.

Through all of this the mobile modem continues to flash blue. I am also still connected via my Netgear wireless connection. Would that cause a problem perhaps?

Further to all the above, in Mobile Partner Tools/Options if I change the APN to Dynamic and then click on connect in the O2 profile the modem light goes solid blue (I assume it's blue as it's the same colour that it flashes but looking at the colours in the O2 booklet I cannot tewll the difference between the blue or the turquoise!. In the middle bottom the little PC icon then has a little green lozenge type symbol in its bottom right and next to it there are two arrows. a red arrow pointing up with 0.0 kbps next to it then a green arrow pointing down with 0.0 kbps next to that alos. However, if (after closing my wireless connection) I then try and open and connect to a browser window I just get a page that says "UNABLE TO CONNECT" followed by some more words starting " Firefox can't establish a connection to the server at ......".

Does this offer anyone any clues as to what my problem is? Any advice and idiots guidance very welcome. Many thanks

  jdb 11:01 26 Jun 2009

Hi, I have had similar problems with my "3" Mobile PAYG dongle. Try changing the Encryption settings to include TLS as well as SSL (I kept getting an Error message re SSL Encryption).
Prior to that I couldn't even get on to the logon site using my ordinary wireless router and Firefox.

  ronalddonald 11:12 26 Jun 2009

try using linux mint or linux ubuntu

ive a 3 mobile broadband monthly i can get connected only these to platform of unix the others i have to say it can be a challenge on the gtounds that the linux software has to recognise the dongle

if you can purchase or download ubuntu or mint it would probably work i cant guarantee it since im not with o2 but i do have.

When ypou say the dongle flashes from green to blue once in the blue thers should be a small icon in the task manager some where either at the top or the bottom it could in in the form of a small computer box icon (next to the date and time)click on that and c it if conects you then click on firefox. Thats how its set up on linux mint and ubuntu.

  ronalddonald 11:15 26 Jun 2009

advisor had a separate forum for Linux since its totally different from windows

  mocha 06:55 27 Jun 2009

Hi seftonsun,

Similar problem resolved.

click here

Good Luck.

  seftonsun 13:54 28 Jun 2009

Hi Mocha,

Thanks for the link. Following the advice in it I seem to have sorted it out after 3 weeks plus of fruitless fiddling about.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?