NTOSKRNL.EXE is missing or corrupt

  Granger 20:26 01 Nov 2005

I'm at a friend's house where his PC (XP Pro SP2) went to a blue screen suddenly in use. It won't reboot. As soon as BIOS loads the "ntoskrnl.exe is missing or corrupt" comes up. It won't even think about loading Windows. We found some guidance on the web, instructions for re-extracting the file using Recovery Console. But we get "access is denied". At a C: prompt the DIR command didn't work either. He's sure nothing was happening, no Windows updates just installed or anything like that. Had up-to-date virus protection. Is the hard drive definitely screwed? Can you guys suggest what to do? Thanks in advance for any help.

  Fruit Bat /\0/\ 22:34 01 Nov 2005

1/ Place your Windows XP CD into your CD-ROM and Reboot your PC

2/ XP's setup program will automatically start and files will be loaded to memory

3/When you reach the Welcome to Setup screen choose the Repair option by pressing R

4/ This will open the Recovery Console

4/ The list of Windows installations will appear

5/ As you only have one installation on your PC you need to press the number which is relevant to your installations location. This, obviously will typically be 1

6/ You now need to enter your Administrator password to gain access. If you are using Windows XP Home edition the administrator password is blank by default so simply press Enter

7/ At the command prompt change to the drive letter that contains your CD

8/ Next type: cd i386

9/ The directory should now change to the i386 directory

10/At the command prompt you now need to type: expand ntkrnlmp.ex_C:\Windows\System32\ntoskrnl.exe

11/The relevant file should now be expanded and copies to the windows\system32 directory of your C:\ drive

12/ Finally, remove the Windows XP cd from your CD-ROM and, at the command prompt type: Exit

If will not work then

Repair XP by install over the top of existing systm

1. Boot the computer using the XP CD. You may need to change the boot order in the system BIOS so the CD boots before the hard drive. Check your system documentation for steps to access the BIOS and change the boot order.

2. When you see the "Welcome To Setup" screen, you will see This portion of the Setup program prepares Microsoft Windows XP to run on your computer:

To setup Windows XP now, press ENTER.

To repair a Windows XP installation using Recovery Console, press R.

To quit Setup without installing Windows XP, press F3.

3. Press Enter to start the Windows Setup.

To setup Windows XP now and Repair Install , press ENTER.

DO NOT choose "To repair a Windows XP installation using the Recovery Console, press R", (you Do Not want to load Recovery Console).

4. Accept the License Agreement and Windows will search for existing Windows installations.

5. Select the XP installation you want to repair from the list and press R to start the repair.

6. Setup will copy the necessary files to the hard drive and reboot.

Do not press any key to boot from CD when the message appears.

Setup will continue as if it were doing a clean install, but your applications and settings will remain intact.

REpair XP
click here

  Granger 10:53 02 Nov 2005

Hi Fruit Bat, thanks for the help. When we tried "expand ntkrnlmp.ex_C:\Windows\System32\ntoskrnl.exe" command in the Recovery Console, we got "access is denied", or words to that effect. Same response when trying to install/repair Windows. We get as far as choosing to repair, but as soon as it tries to write anything to the disk it fails.

We then installed the drive as a slave in another XP system. We now noticed the disk made a squeaking noise! The first thing that happened was the Windows Check Disk thing ran and reported lots of sectors not accessible. It was assigned a drive letter but if we clicked on it in Windows Explorer it said "not accessible". We looked in Computer Management console, and it showed the drive as "healthy" but it seemed to have another partition with no drive letter. This extra partition was labelled "36 MB FAT". There didn't seem to be anything we could do with it here.

We then reinstalled the drive in its own system and tried to use the "diskpart" command. Am I right in thinking this is the equivalent of FDISK? Anyway this also reported what looked like 2 partitions on a disk that should have just 1. It matched what Computer Management said in Windows. It looked like we might be able to delete the partitions and start again but I guess this would be curtains for the data? So we didn't try.

My mate has now learned the hard way about backups, he's upset about all his lost data. He's heard that for a mechanical fault it is possible to remove the actual disks inside and read the data from them.

Thanks again for your help so far. It looks bad - anything that involves reading or writing data fails, so I think my mate's assuming it's a lost cause now. Anything else we could try?

  Fruit Bat /\0/\ 16:28 02 Nov 2005

Before using expand command, try typing set AllowAllPaths = true (case-sensitive) in recovery console.

Have you tried checking hard drive for errors in recovery console using chkdsk /r command?

  Granger 17:12 02 Nov 2005

Hi again, thanks for this. We did try chkdsk /something the first time we were in the Recovery Console. I can't remember exactly what happened but it didn't seem to lead to any improvement. Am I right in thinking that this would be the same chkdsk process that ran automatically when we booted up another computer with this hard disk as a slave?

Your suggestion about the SET ALLOWALLPATHS command I'll pass on to my friend. I may not be able to get back with progress until tomorrow but that doesn't mean I'm not your help isn't appreciated.

  Granger 17:15 02 Nov 2005

My friend just got back to me to remind me what happened when we tried to reinstall Windows: "As for the installing windows on-top of windows, it didn't even give us that option because as far as it was concerned, windows ain't there!" He's going to try the allowallpaths tonight. He's also heard of some partition recovery software that he might try.

  Granger 13:24 03 Nov 2005

Not going well I'm afraid. Here's what happened: "The SET command is currently disabled. The SET command is an optional Recovery Console command that can only be enabled by using the Security Configuration and Analysis snap-in". I found a MS KB article about this but it looks like it's aimed at running it within Windows, not from a DOS shell?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Indie publisher Canongate’s top 10 book covers of 2017

New iMac Pro release date, UK price & specs rumours

Tablettes Amazon Fire : quel modèle choisir ?