NTDLR is missing - PC won't boot

  Liteman 13:47 26 Jan 2012

Switched on my PC today and it won't start, it gets as far as the ASUS splash screen and then goes to a black screen showing "NTDLR is missing". I have used Bootable Partition Wizzard and this reports that all partitons on the main HDD are there (1TB split into 4 equal partitions) but the main/system partition is showing no name or letter, all the others carry names. I have Acronis reports which I could attach if required, but based on info provided already does anyone have any ideas? OS = XP SP3. I have Acronis backups but don't know if this will work with the partition having no name.

  northumbria61 13:53 26 Jan 2012

If you have a Windows XP installation CD you may be able to boot from this and use the Recovery Console to fix NTLDR

  northumbria61 13:56 26 Jan 2012

Windows XP CDs supplied by Microsoft has a tool called the Recovery Console which can be used to repair errors that prevent Windows XP from starting using the command line. OEM versions of Windows XP, including computers that were supplied with Windows XP preinstalled, may not have this utility.

•Insert the Windows CD and start the computer. •When the Welcome to Setup screen appears, press R. •Type a number corresponding to the Windows installation you wish to repair (usually 1) and press Enter. •When prompted, type the administrator password and press Enter. •From the command prompt, copy NTLDR and NTDETECT.COM from the i386 folder of the CD to the root folder of the hard drive. In the example commands given below, C: is the hard drive and D: is the CD-ROM drive. You will need to change the drive letters if appropriate: COPY D:\I386\NTLDR C:\ COPY D:\I386\NTDETECT.COM C:\ •Remove the Windows XP CD from the drive and restart the computer.

  Fruit Bat /\0/\ 14:20 26 Jan 2012

Its missing because the drive letter is missing.

Use the XP CD to boot to the Recovery console

At the prompt first try typing fixmbr press enter then type fixboot press enter type exit remove the CD and try to reboot normally

  Liteman 14:22 26 Jan 2012

I did as you suggested. Pressed R Selected 1 - D:\Windows> This is a bit odd as C: is my Windows partition.

Was asked for Admin password, there isn't one

Typed Help at the command prompt but none of the options include anything to do with NTDLR

  Liteman 14:30 26 Jan 2012

Fruitbat - tried FIXMBR and got the following:

This computer appears to have a non-standard or invalid master boot record.
FIXMBR may damage your partition tables if you proceed.
This could cause all the partitions on the current hard disk to become inaccessible.
If you are not having problems accessing your drive do not continue.
Are you sure you want to write a new MBR?*

At this point cowardice took over and I did nothing!

  Liteman 15:04 26 Jan 2012

Do I say yes to writing a new MBR?

  Fruit Bat /\0/\ 15:55 26 Jan 2012

As long as you have important data backed up hen answer Yes.

  Liteman 08:49 27 Jan 2012

All seems to OK (for now at least!). I discovered that the drive letters had been switched around somehow, C was now D and vice versa, hence the reluctance of the machine to boot. After one or two more setbacks and resetting the BIOS to default the system now seems to be working, but as they say - watch this space!

Thanks to northumbria61 & Fruit Bat for input.

  Liteman 10:10 27 Jan 2012

There is a sequel to my last post. When I discovered the drive letter change I disconnected the second drive (D:) which is probably why the system reverted to where it should have been and worked properly. I have just reconnected this drive and rebooted only to find that "NTDLR is missing" is back again. As I can live without this drive for a while I've disconnected it again and everything is once again OK. Any idea as to what I need to do to be able to reconnect the second drive and for everything to run properly?

  Fruit Bat /\0/\ 10:56 27 Jan 2012

Type of drives? IDE or SATA?

IDE - check master and slave jumpers are correct

SATA - check Drive with op system is in lowest numbered port.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Comment savoir si quelqu'un a bloqué votre numéro de téléphone ?