Not really a cry for help....

  Chegs ® 02:04 21 Jul 2004

but just to ask if there are many SATA hdd users who could offer their experiences/opinions of SATA.

Mine has been an absolute nightmare! If I switch the PC off,on bootup I get "Incomplete RAID set,Press F4 to enter setup" I thought I had sussed it,simply entering the BIOS and waiting a few minutes before attempting to bootup the OS,but tonite I entered BIOS to show a friend the overclocking ability of this mobo(Gigabyte GA-7VAXP-ultra)after my PC has been on 24/7 for a few months beforehand and was horrified when trying to restart windows I was greeted with the "Incomplete RAID set..." message! OK,I thought,use the "Repair" option in XP Home.No chance! 1st few goes,XP couldn't "see" the hdd's at all,then when it could each reboot after the setup files were copied over,the flipping thing would lose these files and go right back to the beginning again.Then the "Incomplete RAID set...." message returned,resulting in a full format/reinstall of all my apps.I had just about completed reinstalling them all,and only had the XP Updates to do,when I "discovered" I still had them on a DVD/RW so patiently worked thru them and installed them all before rebooting.On reboot it got to the login screen(strange as there is only me,no admin accounts)and I got a message appeared "Windows has detected a problem with the activation"(or similar)and it refused to proceed any further.I had forgotten to activate my XP before installing the updates,and somehow this screwed my install.I tried the "Repair" option,and this told me there was a major problem with C:\ that XP couldn't fix! So,off I went again.Delete the RAID set(as the Incomplete RAID set message reappeared)recreate it,format the hdd,install XP,then the most annoying thing happened.The DVD/RW with all my apps and files on has ceased to work,I get approx 10Mbs of files visible on it.So,once again I'm stuck,and its gotten to late for me to be bothered to find a cure for it,I have just d/l "Avant" browser,came here and typed this then I'm going to bed.

So,how many SATA hdd users are about,and do you use them as Striped/Mirrored RAID.Do you use the Si3112 driver,do they ever "lose" or "forget" their driver.Are they as quick as the mfg claims(mine are,but only if I remove the IDE hdd 1st)Do you use them SATA only/IDE+SATA hdd's.

One final point,I was able to "see" the previous partitions via a partition recovery tool,but not able to access the files/folders even with "File Scavenger" a very good recovery tool,so I have got a few Gb's of data to redownload AFTER I remember where on the web I got them from originally(cos guess who's mislaid his floppy disc with all his bookmarks/favourites on...Grrrrr!)

  vinnyT 11:39 21 Jul 2004


  Chegs ® 15:40 21 Jul 2004

At last!

I have just spent the whole night trying to reinstall XP Home,at 8:30am I thought I had finally cracked it(15 mins left to finish)when it suddenly rebooted and started the install again.It did this several times,then the "Incomplete RAID set" message reappeared,and XP wouldn't format/partition the hdd's at all.I switched the PC off,and went to bed.I woke up at 1:00pm and tried again to install XP.This is me FINALLY able to get it loaded and working,but one of the partitions refuses to format.Trying to install the various drivers is also causing problems,some go in no problem(Via4in1)but others have taken upto 7 goes to get them in(Nvidia)My AVG also took two goes.I originally suspected one of my DDR sticks so removed it(ages ago)and replaced it a few weeks back.The PC had run with it without a glitch,but this morning I removed it again hoping it might be the cause.I was wrong!

I tried to activate XP over the net,but was told that I had activated it too many times and had to use another key.Then,right after I had unearthed my other key and was running the activation process again M$ accepted the 1st key.

I am now off to Win Updates,hopefully when I restart the PC after this,I wont get the "Incomplete RAID set" error again.

I had tried a "mirrored" array,but have opted for the "striped" array again.

I spent alot of the night running a hdd tester app,on both SATA's together and individually.There seems to be a problem on one SATA at track 14620 as the graphs kept dropping to zero or the app would lockup the PC,but several times the tester would run thru on both drives without a hitch.

  Chegs ® 17:48 21 Jul 2004

I went and d/l the updates,rebooted and got "ntfs.sys is missing/corrupted.Press "r" at the 1st screen...etc" so I did.I used the recovery console to copy this file back into windows,but then after reboot I was left with a black screen.I tried another reboot and got a BSOD stating that the registry hive(file) was corrupted in the "Program" (or similar) I tried another reboot and got 1st a BSOD with the same message then after the third reboot I got another black screen and nothing else(no hdd activity,nothing)I am presently formating C:\ again,and its taking forever to format a 10Gb partition! I have fired up my linux PC to post this as I doubt if the win PC will have finished its task before midnite the rate its not going.

No takers on others' SATA experiences?

  Chegs ® 21:40 21 Jul 2004


  It's Me 22:05 21 Jul 2004

XP doesn't seem to have the proper drivers for SATA HDDs. You need ones from your motherboard maker. Or, at least we did, then they work fine. Speed? I've nothing to compare with them so I don't know. I found that they were recognised as SCISC or something drives not SATA, but I gather that is normal, but then what is 'normal' in the mad mad world of MS.
The best of luck!

  It's Me 22:05 21 Jul 2004

XP doesn't seem to have the proper drivers for SATA HDDs. You need ones from your motherboard maker. Or, at least we did, then they work fine. Speed? I've nothing to compare with them so I don't know. I found that they were recognised as SCISC or something drives not SATA, but I gather that is normal, but then what is 'normal' in the mad mad world of MS.
The best of luck!

  Chegs ® 00:09 22 Jul 2004

I GIVE UP!!!!!!!!

I have fought all day today with this ruddy PC.I have gotten XP Home installed,the SATA drives partitioned and formatted and setup as a "Mirrored" RAID system.I have changed the RAM sticks around,swapped the hdd's around,had a "striped" RAID system,replaced missing corrupted files with the recovery console,and finally got a few of my apps reinstalled....rebooted about an hour ago and the "Incomplete RAID set,Press F4 to enter utility" message reappeared.I have tried locating some info on howto cure this without losing all the partitions/data yet again,but although it seems to be a common happening,no-one has any suggestions on a fix.I'm fortunate that it has occured whilst setup as a mirrored array,as it still boots into windows,whereas when it was happening as striped I was getting "missing system disc" errors and unable to boot up.These SATA hdd's have been refusing to format,or worse taking over an hour to format 22% of a 10Gb partition then locking up the PC completely.Setup(XP cd)refusing to complete,etc.

I am going to start a new thread on repairing a damaged RAID set without having to reinstall everything all over again.

  pc moron 00:15 22 Jul 2004

Chegs ®, I admire your patience and perseverance!

  CurlyWhirly 20:49 22 Jul 2004


I have never had SATA drives but I can appreciate what you are going through as when I used to run RAID in stripe mode with my Gigabyte GA-7VAXP motherboard I had nothing but trouble with it as nearly every time I booted up I had errors with the array.
I had to keep repairing it or reinstalling from backup.
After a few days I got rid of RAID and went to a normal configuration and now I keep my other hard drive as a backup in case something goes wrong with my C: drive!
I am beginning to wonder whether the problems you are having are more to do with RAID than SATA?
Have you tried running SATA without using it in a RAID array?

  Chegs ® 00:56 23 Jul 2004

I had been running it as a striped array for approx 6 mths previously with rarely any bother.This was why I lost so many apps,I had been lulled into a sense of false security.The only time it had been constantly hassling me was when I fired it up from cold without giving the system chance to warm thru by sitting on BIOS screen for a while,this was why I started leaving it on 24/7.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)