Not able to join homegroup

  chinmay04 17:50 30 Apr 2016
Locked

I have a laptop, a desktop and a router. Both PCs are running Windows 7 Ultimate. My desktop is connected to the router by ethernet and laptop is connected to it through wi-fi. When I'm trying to create homegroup on desktop, laptop is not able to recognize any homegroup created on the network. So, laptop is also showing "Ready to Create" in the homegroup options. I tried to change every settings. I started the service "Homegroup Listener and Provider" in both computers but still they are not joining a single homegroup. Both the devices are IPv6 enabled with their firewall off. I have turned off password protection in Home tab in advanced sharing settings. But, when I open 'Computer' in both PCs, both computers are available under 'Network' part in left-pane. Please help me find a way for this problem!

  difarn 19:00 30 Apr 2016

Have you tried the laptop on an ethernet connection? Have you made sure that both desktop and laptop are using the same homegroup name?

  chinmay04 11:53 08 May 2016

Thank you for replying, Do we need to name the homegroups with the same name?

  difarn 18:28 08 May 2016

There is quite a lot of confusion about homegroup and workgroup but both are different methods for organizing computers in network so that they can share files, devices etc.

This article may help you.

click here assume that you have created the homegroup on your desktop PC. Have you tried adding your laptop using the steps in this article?

click here you want to set up a workgroup you need to follow the instructions in this article.

click here you choose the workgroup option then all computers need to join the workgroup of the same name. This may help.

click here asked if you had tried connecting your laptop by ethernet as there have been problems with joining a workgroup/homegroup when using wifi as they are on different networks. You may find this article helpful.

click here

I If If I

  chinmay04 18:07 15 May 2016

Yes, I have tried all the above options, but still whenever i open homegroup option on my laptop, the option for 'Join now' does not come. It says, "Ready to create".

  difarn 21:10 15 May 2016

Have you checked that Peer networking is running in services?

Control panel - sysems & security - Admn Tools - Services

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S10 review: Hands-on

Alice Tye on blurring the line between fine art and illustration with Japan as her muse

Best free iPhone games 2019

Comparatif : iPhone XS vs Samsung Galaxy S10