Non release of memory?

  greyfriar 11:24 04 Aug 2005
Locked

My PC with 512Mb RAM runs Windows 98SE and I have a recurring problem which seems to relate to memory not being freed up. When using Microsoft Publisher 97 to edit relatively small publications (4x A5 pages with some clipart) or when editing a photograph with Photoshop 7, or occasionally when using Word 97 with several documents open, I eventually get a blank white window with a grey ‘close’ button appearing. Nothing then works until I click on ‘close’ and then if I try to run a program I get a message that there is insufficient memory to run it. The only option is to shut down Windows and start again, but using the normal shut down procedure results in a frozen screen, so I have to use the ‘reset’ button. I’ve tried to override windows management of virtual memory (on a separate hard drive with over 20Gb free), but it always defaults back to windows management. I’ve run memtest86 which could find no errors. I’m not sure if there’s a connection, but the problem first came to light some time after installing Symantec Norton Internet Security. I’ve tried reinstalling Publisher but this hasn’t solved the problem. Any suggestions?

  Joe R 11:27 04 Aug 2005

greyfriar,

you could try making your swapfile bigger, but I think the real problem, lies with Norton Internet Security, which is a real resource hogger.

  DieSse 11:35 04 Aug 2005

"I think the real problem, lies with Norton Internet Security, which is a real resource hogger."

I agree.

To speed up your system no end - and get an AV with a better history in detecting viruses into the bargain - click here NOD32

  Batch 12:20 04 Aug 2005

There is a known problem with Win95/98/ME, when using more than 512Mb, giving rise to insufficient memory errors. Some people have also reported problems with 512Mb.

If it is this problem, you can try restricting the amount of memory.

Start > Programs > Accessories > System Tools > System Configuration (or Run from the Start menu and type in MSCONFIG.

Then on the General tab, click Advanced. You'll see one of the options is to Limit Memory. If you select this you'll be able to select a value. Try, say, 480Mb to start with. You'll need a reboot for it to take effect.

This is also described (embedded amongst various other items) in click here

Let us know how you get on.

  greyfriar 18:06 08 Aug 2005

Thanks for the various suggestins. Problem still there when Internet Security is disabled and when lower memory limit is set. It seems that memory is not being released at the end of a task, so that useage accumulates until there is insufficient and the close window appears.

  greyfriar 00:10 13 Aug 2005

Downloaded Cacheman and got an immediate improvement in performance. Still on trial, but so far it looks promising. Managed a Photoshop session without a crash!

Many thanks for the suggestion.
David.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?