No web pages on pc2

  MiniMum 08:05 06 Mar 2005

I have 2 pcs both running XPSP2 over wired network. Until recently I could receive web pages on both pcs (provided pc1 switched on). Now, I can receive emails on pc2 and I can do a google search - but when I click on a link or type a url cannot open web page. It says page is opening but nothing happens. Also, I can't download AVG updates. Pc1 is shown as gateway and pc2 as client. I have tried setting up several times - even removing firewall but no progress.

I have blueyonder broadband (1.5 meg). Pc1 receives 100 mps but pc2 only 10 mps.

I recently changed pc1 from Server 2000 to xp but think this problem started before then. It may have happened around the time I installed a firewire port on pc2 (for camcorder). I removed that card yesterday but still can't surf.

I have searched this forum and tried a few ideas like clearing history. I would welcome any further thoughts.

  spikeychris 15:27 06 Mar 2005

On PC02.

Type "regsvr32 urlmon.dll" into the run box. Hit enter. Make sure all progs are not running first.

  MiniMum 17:23 06 Mar 2005

Thanks Spikeychris - that worked to some extent and I can now open several websites - but not all. For example I can open Merton Council website but not Wandsworth Council (or PC Advisor) site. I can open Customs and Excise website but not the DTI's. If it is ok I will leave this as unresolved for a while longer in case anyone can suggest why this might be happening.

  spikeychris 17:47 06 Mar 2005

Do the same as above but replace urlmon.dll with the below.

• Shdocvw.dll

• Msjava.dll

• Actxprxy.dll

• Oleaut32.dll

• Mshtml.dll

• Browseui.dll

• Shell32.dll

Example: Run and type "regsvr32 Shdocvw.dll" hit enter. As above, its important to shutdown all progs.

  MiniMum 08:47 07 Mar 2005

Thanks again. These were all shown as sucessful but i am still unable to open certain web pages. Perhaps the answer is to reformat pc2?

  spikeychris 08:55 07 Mar 2005

You're a long way from that yet. click here and unpack the files to your desktop. Run the program by clicking the apply button.

  MiniMum 09:14 08 Mar 2005

Sorry for delay. This file needs IEXPLORE.EXE from the SP2 disk - but when i insert the SP2 disk the file cant be found?!

  spikeychris 18:04 08 Mar 2005

Go to run and type "sfc /scannow" Insert whatever disk it asks for.

  MiniMum 20:44 08 Mar 2005

Ran "sfc /scannow" - told to wait while windows verified all protected windows files intact. when 100% complete this box just closed without asking for any disks.

  spikeychris 21:17 08 Mar 2005

Does Internet Explorer still work?

  MiniMum 21:48 08 Mar 2005

Same as before - some websites open and some don't. Still can't download AV updates.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

3D illustrator Billelis on how to promote yourself on social media

iMac Pro review

Apple Music : comment obtenir 3 mois gratuits ?