No Power

  Rossi#1 20:31 12 Feb 2007

Ive just finished putting together a tower. That is an old tower and cd drive but the rest is new.
Its very basic with an Elitegroup 755-A2 mobo, a 2800 Sempron, 512mb, a Casecom 300w PSU and an ATi9250 graphic card.
I tested the PSU in my working PC and its fine but hitting the power button does nothing in my "salvage job"
Ive tried disconnecting everything but the mobo with nothing happening. Can a tower run without the monitor, keyboard and mouse being connected?
My problem is do I replace the case (in case of a faulty switch) or have I done something to the mobo during installation?

  skidzy 20:44 12 Feb 2007

Yes the mobo will run without the mouse/keyboard/monitor.

If you have think the psu may be kaput due to an overload,get one of these as i find them invaluable click here

Check the headers are correctly connected also.

You have connected the 4 pin plug normally along side the cpu ?

  woodchip 20:44 12 Feb 2007

This is how you build a PC, You can first try the Mobo out of the Comp with CPU in and Fan attached plus a Graphics card and at least one stick of memory. This should boot to BIOS by pressing the right key mostly the Del key. Put the MOBO on Card so it does not short out. Then try it in the Case. If it still works check BIOS settings for CPU. then add one bit of hardware at a time and try. Before the Above you should check all jumpers on the MOBO if there is any for the CPU settings

  Rossi#1 20:54 12 Feb 2007

The problem is switching it on. The PSU definetly works that I do know but hitting the power switch does nothing. Ive tried turning the connectors round because they are impossible to tell whats + and -. I think my only option is to splash a tenner on a new case too and if that fails suspect the mobo or come back here.

  skidzy 20:58 12 Feb 2007

Have you retested the psu in your working pc since trying to install in the old tower,my first experience with a good psu resulting in blowing the psu and mobo.

  woodchip 21:01 12 Feb 2007

You can test the Startup by just shorting the pins that power button connects to it does not matter about + and - as the switch only shorts the pins do not hold the metal on the pins or it will shut down after about two minutes

  Rossi#1 21:06 12 Feb 2007

Im no sparky but I did buy a wee multimeter today tho I dont know what to really do with it or what you mean by "shorting".
I did try a circuit test by holding the probes to the pins and got the green light and success beep. Cant test the voltage though.

  skidzy 21:07 12 Feb 2007

I may be stating the obvious here...but if the psu is a switching unit,You have switched it on...havn't you !

  Rossi#1 21:12 12 Feb 2007

Ha yes. Double-checked

  woodchip 21:14 12 Feb 2007

The start button at the front of the case as two wires I think Black and Red may be other colour but they only connect to about 5 volts if it is a ATX case. Only OLD AT case had 230Volts to the Power button. We are going back a long way, you can verify a ATX as the main Plug to the MOBO as two rows of wires in it, a AT as two plugs edge to edge with one row of wires in each plug. the Front Start button only acts as a Short when you press it then the MOBO takes over on starting, the pins that you connect to are bottom right of the MOBO should be marked PW or somthing like that, also look for white bracket on the two pins showing you have the right pair.

  skidzy 21:16 12 Feb 2007

Sorry Rossi,just thought i would ask as its easily missed. ha ha......

I doubt its the case switch if thats any consolation,is it possible to try the psu again in the working pc ?

Is this your board click here

And the 4 pin is connected ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?