No internet sharing

  silliw 08:51 08 Oct 2004
Locked

Spent 6 hours last night trying to fix a friends network where the client machine cannot connect to the internet.

Both machines are XP home. The host connects via a cable modem on a NIC. both machines are peer to peer using netgear usb 802.11b adaptors. For some reason, the host assigns an automatic private IP 169.254 etc address to the wireless adaptor rather than a DHCP assigned address 192.168 etc. When I try a repair it complete loses its IP.

Have run ipconfig /all and manually set the client with a 192.168 address and DNS settings but still cannot get through. Have made sure that internet sharing is set on the host and have ensured that no firewalls are running.

Cant think of anything else folks, your help would be appreciated.

  mgmcc 16:39 08 Oct 2004

<<< the host assigns an automatic private IP 169.254 etc address to the wireless adaptor rather than a DHCP assigned address 192.168 etc >>>

The host is not assigning the "169" address, Windows is defaulting to this address because the network adapter cannot find a DHCP server to get the correct address from.

Presumably, ICS has been enabled on the network adapter in the 'host' PC and its wireless adapter is getting the correct fixed IP 192.168.0.1? Both wireless adapters should be set to use "Ad Hoc" networks - does the host PC's wireless adapter find the network?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?