No Hard Drive with Easy IDE

  Audeal 00:16 07 Nov 2006

Can anyone tell me why my hard drive is not recognized when connected to the device "Easy IDE". When connected it is found in the SRH (Safely Remove Heardware) Icon in the system tray. It is not found in "My Computer" and is also missing in the Disk Management window where drive letters can be changed. But, It is found in Device Manager listed under Disk Drives.

This drive runs OK when installed in a computer but not when connected to the Easy IDE.

I run XP Pro. The hard drive in question is a Maxtor (Not sure of the model).

Many thanks for any help. Audeal

  woodchip 00:23 07 Nov 2006

Have you set the Drive Jumper to Master. As all USB external as to be set to master

  Audeal 00:56 07 Nov 2006

woodchip: Thanks for your reply. I have tried Master and Slave but it makes no difference. If I remember correctly the instructions did say it does not matter where the jumper is. I will need to check this to be sure.

  phil46 01:11 07 Nov 2006

I your easy IDE powered up???

  Audeal 09:40 07 Nov 2006

The power light almost dazzles me. I am coming to the conclusion that the drive could be faulty although it works ok in the computer as I have formatted it ok, so there is nothing on it at the moment. When installed the drive is recognized without trouble. This device recognizes other drives ok but not this one.

  Spark6 10:08 07 Nov 2006

I believe your last sentence sums it up. The Maxtor drive appears to be faulty.

*When installed the drive is recognised without trouble* Have you been able to transfer data to it when 'installed'?

  Audeal 10:15 07 Nov 2006

Spark6: Yes, when installed it works perfectly well so can't understand why it won't be recognized when connected to Easy IDE. I guess it must have some fault on it. I have to go out now so I will check it again later when I get back and I will re-install the drive and re-check that I can copy data on it.

  Fruit Bat /\0/\ 18:50 07 Nov 2006

Refresh USB Ports
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Audeal 21:03 07 Nov 2006

Fruit Bat /\0/\: I took your advice and uninstalled all the USB drivers then rebooted but it is the same. I did, however, notice that if I connect the "Easy IDE" device without a drive connected to it it will attempt to install the device. In the balloon it says "Found new hardware and also some other text which is corrupt. When I get the notice that the new hardware is installed and ready to use, it tells me that there was a problem and it might not work properly. Which leads me to suspect the "Easy IDE" device is the culprit here.

Unless anyone else has any other suggestions to solve this problem then I will try to replace the device from where I got it.

Thanks for your help. Audeal

  Spark6 23:23 07 Nov 2006

Have you proved the drive yet? Are you able to beg, borrow or steal another drive to prove the EasyIDE? I believe a CD Rom or DVD Rom would do.

  Audeal 19:52 08 Nov 2006

It seems that the Hard Drive has drawn its last breath and gone to Never-Never land.

I do thank you all for your help in solving this problem but a duff drive is a duff drive and that seem to be the end of the story.

I will close this thread now. Bye all and thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?