No Graphics display on boot.

  Jollyjohn 17:18 23 Nov 2013

I have aa Asrock K7S8X Motherboard with an AGP graphics card. On starting the PC there is no output from the graphics card.

I have tried another agp gfx - nothing

I have tried a basic pci gfx card - still nothing.

In between each restart I have cleared cmos by shorting out the pins .

I have been given this PC for spares so if I don't get it working it is not a problem it is more of a challenge to know why I get no display at all!

  Fruit Bat /\0/\ 17:37 23 Nov 2013

Is it getting into windows at all?

Any noise from fans or hard drives?

  Jollyjohn 19:12 23 Nov 2013

Fans spinning up. Sounds like hard drive is spinning up.

Nothing on keyboard, not even Num Lock light even when toggling.

Only 300W psu so might try a bigger psu - unfortunately have just given away my last spare psu!

  woodchip 19:27 23 Nov 2013

Try a different PSU as I think its blown, Fans and lights will run on a AA cell, but PC will not

  Fruit Bat /\0/\ 19:31 23 Nov 2013

Agree sounds like PSU died.

  Jollyjohn 09:49 24 Nov 2013


Tried a known good psu - still the same.

No beeps from board. I know the speaker works because I tried booting with no RAM- lots of beeps.

  Fruit Bat /\0/\ 09:58 24 Nov 2013

Next job is remove motherboard from case (short to case?) and min config boot, with just cpu, 1 stick of mem and graphics card.

Should boot to message about no boot able device found or similar.

  onthelimit1 10:02 24 Nov 2013

Suspect mobo then, I'd guess

  Jollyjohn 10:12 24 Nov 2013

Thanks for all the suggestions. It would appear the motherboard is knackered.

  woodchip 23:25 24 Nov 2013

PSU as taken out Motherboard and or CPU

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?