No Desktop on start up, just documents window?

  User-A964BECF-28AC-450B-8707F7EBA2A7EF6F 10:13 07 Sep 2009

Hey, i turned on my laptop yesterday and for no apparent reason the desktop has gone, all i get is a black background with nothing else there except an instant window that appears when i log on to show my documents, there is no start up menu no nothing, i literally get the log in screen which works fine, and then when ive logged on, its black background with a my documents window.

Does anyone know whats wrong with me laptop?

Id really like to not have to send it off to be repaired again for the 5th time in 1 and a half years.

Please help.

  birdface 10:24 07 Sep 2009

If you right click in the middle of the screen and tick show desktop icons does that work.
Or press the windows icon on the keyboard will get you in to start and maybe a system restore.
Does it work Ok in safe Mode[just keep tapping F8 as the computer starts]

literally cant do anything regards the desktop, cant right or left click to get the like drop down list of options, ive tried the windows key and that doesnt do anything, and ive als tried it in safe mode which also just show the one window of my documents.

  birdface 11:08 07 Sep 2009

Sorry but I have a very limited knowledge of this problem so I will need to leave it for others to give you the help that you need.
All i can think of is a system repair.But that is only a last resort.I presume that you can still get into the Bios.It will stop the next person from asking.
Was it keeping good time and did you download any new programs or updates on to it yesterday.

  eric_bloodaxe 11:08 07 Sep 2009

just came looking for an answer to this problem on a laptop running Vista, home i think. It happened when my bro in law was fiddling! actually MS updates were running and installing them, he says, caused the thing to crash and after eventually getting it going again there was no desktop after boot up. It is because explorer.exe is not starting. This I do know and it can be sorted by pressing Control + alt+ del. this launches the task manager from which you click file then the top option, New Task (Run)... this gives you the command prompt Type explorer.exe then hit Run or return. This should yield the desktop as normal for the session.
My question now is how in Vista do i change the startup type for the file? I can't seem to do it using msconfig on the services tab as it isn't listed nor is a startup type to change. There is no fail event in event viewer either as if the system doesn't try to start the explorer and fail. Any ideas?

Regards eric_bloodaxe

thanks buteman, eric, my next problem is, wen i go ctrl alt del....i dont get the task manager thats not one of the options i get, ??? know how i can get to it another way? lol

  birdface 11:21 07 Sep 2009

If you have the Vista disc maybe try sfc /scannow in the run program.
I was just about to post that way of fixing it for Madman101 but as clicking the windows Icon did not work I was not sure about ctrl Alt.delete if it would work or not.

  eric_bloodaxe 20:32 07 Sep 2009

predictably we dont have a disk, well i made the recovery disk with the packard bell utility, but the file is present and runs fine if we launch it manually from the CP. it just doesn't start automatically at boot like it used to and should.Is there a way to set its startup behaviour from a CP? Also is there no longer a way to access the start type in a list of services like in XP? could i add it to the startup tab of msconfig in some way?
Maybe we dont have the same problem madman you did say you get some sort of screen but i dont get anything until i hit ctrl +alt+del then i get task manager. butemans idea may be a winner. tho' if you are not running as a domain you should get the task manager if you hit the c+a+d combo.
Regards E

  BRYNIT 21:50 07 Sep 2009

Have you tried booting into safe mode and using system restore to a date before the problem.

  ened 06:46 08 Sep 2009

Try pressing F8 on boot and then "Boot to last Known good configuration".

  eric_bloodaxe 12:49 14 Sep 2009


had a poke around and this seems to be a possible solution

Hi fmq,

Seems to be a common problem, but it's easy to fix. Follow these steps:

Click start, type 'regedit' and hit <enter> to open the registry editor.
Expand the keys at left to reach:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Click on this key, then locate the 'shell' string in the right pane. Double
click it, replace the contents with just:


Click ok, then close the registry editor and reboot.

Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP

I just booted my laptop up 2 do it & it has cured itself!! so maybe yours will too.
All the best E

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?