No Audio on Toshiba Laptop

  User-1252743 23:07 16 Oct 2008

I have a toshiba satellite pro a120 that was infected with antivirus 2009. I installed malwarebytes anti malware, which did delete antivirus, but my audio doesn't work now. I don't know if the two are related, but the audio was working this morning. I have done all the usual things - checked it's not on mute, deleted, then rededected the driver, updated the driver, but all to no avail.
Anyone got any suggestions?

  FatboySlim71 08:13 17 Oct 2008

What operating system are you using?

  FatboySlim71 08:18 17 Oct 2008

If you have Vista, what does it show when you move your mouse arrow over the speaker symbol that is at the bottom right of the screen near to the clock?

On mine it shows the volume level and "STEREO MIX, REALTEK HIGH DEFINITION AUDIO"

It may be worth trying system restore to see if it solves the problem. If it doesn't then I have some other suggestions, but first I will need to know what you have shown when you move your mouse arrow over the speaker symbol.

  birdface 10:10 17 Oct 2008

If benjyf does a system restore he is more likely to get his virus back.Maybe if he restores back to before he had the Virus might work.You can try.Control Panel.Administrative tools.Services. And scroll down to Windows Audio and make sure it is set to automatic.It may have been changed in the Bios but someone else would need to tell you what to look for.

  User-1252743 10:56 17 Oct 2008

I have XP. I went into services and it is running windows audio automatically.
I will try a system restore, but any other suggestions?

  birdface 12:31 17 Oct 2008

This from another thread. [This is responding to an old post, but this is for others who encountered the same problem. I have a Toshiba Satellite XP A75 notebook that had the exact same symptoms. The volume control was greyed out, but the OS thought the audio device was working properly. This happened after I did a virus scan and cleaned up some malware. It seems that the RealTek driver installer program alcupd.exe was infected and refused to work correctly or be overwritten by reinstalling the device drivers. The installer would always crash 80% thru. My solution was to remove file alcupd.exe (or rename it) then reinstall the drivers. My sound works fine now. Hope this saves someone grief. Good luck.Also loads of others with the same problem. click here=

  User-1252743 13:20 17 Oct 2008

Thanks for the reply, but I had already seen that post which is what gave me the idea that it might be the malware that caused the problem. I can't find a alcupd.exe file though. Where would it be?
Also, my volume control is not greyed out like others say. It all says it is on!

  birdface 13:27 17 Oct 2008

Just wondering if using speakers have you got them switched on and the slider open.Or do you have Windows messenger..if so go there and and Video set up.And go through that and see if you get any sound on that.

  FatboySlim71 20:25 17 Oct 2008

What does it show when you move your mouse arrow over the speaker symbol that is at the bottom right of the screen near to the clock?

On mine it shows the volume level and "STEREO MIX, REALTEK HIGH DEFINITION AUDIO"

Just a thought but I have a keyboard (Enermax Aurora), now on this keyboard it has a microphone and also a headphone socket, when I first connected this keyboard up it switched the default playback device from the above one to USB audio, when it was set on this (USB audio) I got no sound through my speakers. I just wondered if you have connected a keyboard up that maybe had a similar array of sockets to the ones I have mentioned?

  Technotiger 20:41 17 Oct 2008

Have you done a Search for it? - Start>Search type in the name of the file and include all files and folders, including hidden folders in the search.

  User-1252743 01:23 20 Oct 2008

Buteman - I am using the internal laptop speakers and yes, they are on. I tried the msn thing, but when it got to the point of saying can you hear ...., I couldn't!
FatboySlim71 - When I move the mouse over the speaker it just says volume and no, I don't have a usb keyboard attached. In fact, nothing is attached!
Technotiger - I tried that, but still nothing came up!

Thanks for all the suggestions, but it still isn't working!
Anyone got any more?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)