New usb3 pci card not mounting usb3 external drive

  gossylad 21:49 30 Jan 2010

I recently brought a 2tb usb3 Buffalo Drivestation to utilize the new usb3 super speed.

I only have usb2 ports on my pc, so invested in an Icy Box usb3 pci-e expansion card to make it run on my pc.

So, after installing the pci card in my pci x1 slot and connecting a 4pin molex connector from my psu to it. I then loaded the NEC drivers etc that came on the cd with the pci card.

But after restarting my pc and plugging in the new Buffalo drive all I get is the drive flashing blue as it reads it. But the drive itself will not mount on my pc.

I have tried the usb3 cable in my usb2 ports and it works fine (albeit instead of a blue light I get a green light). Also, I have plugged other drives into the usb3 ports on the new pci card and they all mount fine too.

I can not understand why my pc is not mounting the drive after it starts to read it when I insert the usb3 cable into the usb3 port on the new pci card. Do I need to update my bios, as I have tried everything else.

I have tried it with just the new drive plugged in to see if I had too many drives on the system, but still it does not mount.

I have an Asus M4A78 Pro motherboard, 500w psu, amd triple core cpu, 1tb hard drive, 2 dvd drives, 4gb ram, nvidia graphics card, netgear wireless card and the icy box usb3 pci expansion card. With attached to usb ports: 1 Epsom printer and external drives: 2 1tb Buffalo, 1 Freecom 400gb, 1 Lacie 1tb and the 2tb Buffalo usb3 drive.

I can't see how the card does not have enough power to read and mount the drive as the Bufallo drive has its own power adaptor and the Icy Box pci card has a 4 pin molex connector so that it can receive extra power from system.

Have also tried just plugging the card in without using the 4 pin molex to see if that power supply was clashing with Buffalo drives power supply, but no. Also, tried just plugging in the Buffalo drive just by usb3 port and with out using its own power adaptor, but no.

So am now stuck with a new usb3 pci card that doesn't mount usb3 drives and a new usb3 drive that will only mount through a usb2 port!

Any help or suggestions would be greatly appreciated and it if works will be highly praised with thanks!!!

  BRYNIT 21:58 30 Jan 2010

Have you gone into Computer management/Disk Management to see if the dive is showing. If it is it may just need formatting or require a drive letter assigning to the drive.

  gossylad 22:47 30 Jan 2010

Hi Brynit.

Yes I have given it a drive letter (T) which doesn't clash with anything. Also, have tried formatting it and no luck.

When plugged into the usb2 port it works fine and shows up on the Disk Management and Device pages.

But when plugged into usb3 slot on pci card it doesn't mount and doesn't show up in Devices.

  User-312386 23:02 30 Jan 2010

When you say you have plugged it in with the molex, did you plug it in the 12v rail?

  mgmcc 08:12 31 Jan 2010

You've checked out various things in the PC, including attaching other devices to the USB 3.0 port, but is there perhaps a setting/switch somewhere in the Buffalo drive itself that needs to be changed for it to run as USB 3.0 and without which it will only operate from USB 2.0 ports?

  gossylad 21:25 31 Jan 2010

Buffalo Drive links:

click here ... 0-hd-hxu3/

When you say about plugging it into the 12v rail, what did you mean? Thought all molex plugs from psu where the same.

Also, there is no settings on the Buffalo drive that changes it from usb2 to usb3.

Thanks for your responses too.

  gossylad 21:28 31 Jan 2010

Buffalo Drive links:

click here

This one should actually take you to the page!

  gossylad 00:29 01 Feb 2010

Thge original link is for the USA site.

Have to enter serial to get that firmware download and my serial only applies to the Europe site. Which doesn't offer me the firmware. (comes up as invalid serial on US site.)

Also, the ISO is just the same folder that was on the drive when I originally installed it.

Just read on manual page 7:

'* A USB3.0 interface manufactured by Buffalo is required to use this drive at SS mode specified by USB 3.0 standard (logical transfer speed 5.0Gbps).'

Surely they can't expect you to buy the Buffalo usb3 pci just to get this drive to work! Am sure lots of other people will go for a cheaper pci card that does the same job too.

Also, if MS must approve any 3rd-party drivers (i.e., they must be *signed* by MS) before the OS will recognize and load them.

As the driver bfturboh.sys isn't signed could that be stopping the drive from mounting?

Know its only driver for turbo boost but could it be interfering somewhere?

The other drivers: disk.sys, partmgr.sys and sahdla.sys re all signed.

  gossylad 19:21 01 Feb 2010

I originally did try the pci card in my pcie x1_2 slot. The result was exactly the same.

Plus, my pcie x16 slot is inbetween my pcie x1 slots, which I have a nvidia graphics card in.

The graphics card fan is in the way of the pci card and could end up shorting it if I left the card in the pcie x1_2 slot.

Therefore I moved it to my pci ex1_1 slot which is above my nvidia graphics card.

But it doesn't matter which pcie x1 slot I put it in, it still won't mount my drive.

Could I put it in my spare pci slot to try it or will it not be compatible?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?