New Seagate USB drive not recognised

  dan12345 11:56 02 Mar 2007

I have just purchased a new seagate external USB drive. When first connected to my Dell Dimension there came a 'found new hardware' message, but then came a message that the device could not be recognised. It shows up in device manager as an unknown device under usb controllers. If I click on the properties for this it says that no driver is installed, but if I run the update driver option then it reports that no better driver can be found for the currently installed one. I am confused!

There sometimes comes a message to unplug and plug in the device again, but this doesn't solve anything either.

I am running Windows XP with service pack 2. I have several other usb devices that run with no problems when connected to the same port.

I have also tried connecting the drive to a HP laptop running XP with service pack 2, but it gives the excact same problem.

Any suggestions greatly appreciated. I don't want to return the drive as faulty if it is me doing something wrong!


  2neat 12:14 02 Mar 2007

Try it in a friends XP pc. If it still wont work return it. You might be able to format it & it would be ok but no return then!

  Fruit Bat /\0/\ 12:46 02 Mar 2007

Ths can often happen if you are running a USB2 to IDE or SATA external drive and there are no USB2 drivers loaded.

In device manager check Under USB that there is a driver label "Enhanced"

Sometimes "refreshing the USB ports" will solve the problem

Refresh USB Ports
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Mike D 13:06 02 Mar 2007

I have just had a similar (ish) problem. I replaced the disk in a USB2 External HDD and, whilst the hardware was found OK, I could not access the disk until I went into Control Panel/Administrative Tools/Computer Management/Disk Management where I initialised and then formatted the disk (Action/All Tasks)

Hope you get it sorted OK.


  dan12345 11:50 03 Mar 2007

Thanks for all your help guys. have tried all that you mention, but no good. Also tried on 2 more computers, even one running windows 98. Same problem on them all, so I assume the new drive is faulty and will send it back! Thanks again for trying.

  Diemmess 12:24 03 Mar 2007

Try Seagate website support.

Maxtor, and Western Digital both offer small programs which can be copied to a floppy or CD.

The Floppy or CD is then used as a boot disk to run a disk management program which will do almost anything you wish to a new HD and very quickly too.

  bremner 12:28 03 Mar 2007

Heres Segates tools click here

  dan12345 08:30 19 Mar 2007

I have now recieved a replacement drive from seagate and it works fine :) Thanks again for all your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Sam Falconer transforms science and geology into digestible, elegant illustrations

HomePod review

Les meilleures séries Netflix (2018)