new power supply won't start up

  cornishcactus 19:53 22 Nov 2006

my old 350W supply that came in the case was having trouble sometimes in games and was more than likely the cause of a few reboots.
so i replaced it with a 550W jobby from Eclipse click here
when you switch the psu on the red power led lights ( which i think is really a hard drive light because it blinks when the PC's on and doing things ), when you push the power up button the led for that lights up but nothing happens apart from that high pitch thing you sense when theres power about.

taking it back out and shorting the green to black it comes on and all the plugs seem to show the correct voltages.

i've tried unplugging everything else bar the monitor to see if that showed something was upsetting it but no.

the new supply has the new style unclipable 4 pins on the end and my MB, an Asrock K7V88 click here has the 20 pin so the 4 was unclipped.
i do noticed the old supply has a white -5v cable, the new one doesn't but some hunting shows this is rarely used today.

the only other differnce is the old one didn't have a switch, the new one does.
but thats good coz i get bored with the little red power light being on all the time at night.

right now i've got the old supply back in and of course that, as this post proves, works.

everything lining up, everything's plugging in ok, i'm getting really hacked off with this now, esp as the psu doesn't seem to be faulty as i can cheat it to be on with the link ( no i don't want to perminiatly link that )
and the PC is also fine.

i've sent eclipse techinial a email and have also sent a couple of updates as what i found out increases, as yet no reply >:|

i'm not totaly without knowledge on these things, i can hold my own, but i'm no expert either and this has got me.
any clues?
thanks, phil.

  woodchip 19:57 22 Nov 2006

Send it back it must be faulty. You did connect all the plugs? 5 volts is or normaly red not white

  woodchip 20:00 22 Nov 2006

you should not try checking the volts without it connected. You can check with it connected and switched on by backprobing the ATX plug. Put your black probe to case and the stick the red in the back of a wire in the atx plug, All are low volts. Check the white one is 5 volts

  cornishcactus 20:09 22 Nov 2006

thanks, but...

the white one is -5v from what i can find and isn't on the new supply so i can't check it.

i checked the voltages using a online guide ( green to black linked, nothing plugged it ), but as the new one won't fire up when pulgged in i can't check anything.

also if the old supply does show a -5v on the white, it doesn't prove anything as the MB may or may not be using it.

i did at first think it was faulty, but as it shows the correct signs of life when hot wired it can't be.

the only one not connected is the unclipable 4pin ( and the normal gaggle of power plugs for drives your not using )
as it's unclipable for 20pin mb's and not used for anything else this shouldn't be required.
becides, it does fire up when nothing but the green and black is linked.

anyone know if for some reason my mb needs that -5 as it's the only thing missing.
online guides say thats only for older mb's.
it aint that old..

  woodchip 20:16 22 Nov 2006

It does not need to fire up to check with meter if it as a load connected. You may have blown the PSU by trying to test it without it connected. If the wires are different then it will not work as I think you are referring the top right corner of the ATX plug that should be Red 5 volts + not - next to a yellow wire

  skidzy 20:22 22 Nov 2006

Are you connecting to the headers correctly ? this may why you are having problems.I recently had a very similar problem.

Are you saying you have not connected the 4 pin (2x2) 12v plug...This needs to be connected.

  cornishcactus 20:36 22 Nov 2006

no, im refering to the white wire which on alot of modern psu's with a 20 pin plug is not there at all.
this pc was a kit build i just ordered bits i wanted.
so the old psu isn't matched to the mb as such. so i don't know if the white is required or not.
the white wire i refer to can be found here.

click here

the 4 pin i refer to is indeed 2x2 but is a cliponable type to the 20 pin making it a new style 24 pin. ( the 4 pins supplying more power for todays hungry mb's )
with it uncliped the supply is susposedly compatiable with any 20 pin mb.
apparelty you can even plug a 24 pin straight in if you have the spare space for the 4 pins to sit outside the mb's 20 pin socket.

the other 4 pin, the one your on about is connected where it's meant to be.

as i said, everythings connected where it's meant to be, and i've not blown the new supply, it still works ok when linked, and was unmolested when i first installed it.

the acid test i suspose is to hotwire it and plug it all in.
i bet it'd work then but i don't want to do that.
i want the psu's rear switch to isolate the whole pc, which my current psu doesn't, so theres a few led's still lit at night, and i also want my front buttons to work.

  woodchip 20:48 22 Nov 2006

Just checked your link the white wire is same as mine, so it is OK third wire down from red wire I posted above. You do not need the four wire that you uncliped if the ATX is only 20 pin. But did you plug the other four wire plug in to the board. This is for ether CPU or Graphics a Small 4Wire Plug with 2 yellow and 2 black wires to it

  skidzy 20:49 22 Nov 2006

I recently rebuilt my system with an Asrock board the pins had to swap around,my fault i know.

Also,i had bought 2 faulty psu's from Maplin.So maybe something could be faulty Mobo/PSU

Just to check your connection.

The motherboard header has a row of 4 and a blank. And under this ther is a row of 5.

On the row of 4, you connect pins 3 and 4.
( PWRBTN# and GND )

Are these the pins connected.

Im assuming the board connects the same as mine.

This link may give you a few pointers as i have had similar problems. click here

  cornishcactus 21:08 22 Nov 2006

yes the yellow and black 4 pin is in.
and the power button is connected propperly, as are the other two on that socket.

it could be a mb problem, or even a pin in the wrong slot problem, if it wasn't this pc i'm using ;)

yesterday i had new drive bolted in with the cables out the way, and the old one hanging out the side wired in just to get things working to go answer hunting.

today i checked the various plugs and pins using the PFD manual ( can't find my little book )
everything is fine.

i've not checked that the 20 pin on this psu matches the new one colour for colour.
but then, it should.. they all should.
becides, no magic smoke from mb or psu.
tho it does seem enjoy being switched off after not firing as that high pitch noise you sense getting loulder and loulder dies away again.

bit like a firing capicator ( if it has such a thing ) is overcharging.

the only pins that are in the wrong place are the front audio outputs.
output are in the right places, but the right earphone has never worked, does if you wiggle it about a bit, but nothing worng with the baord it's on.
and microphone has mic in, mic out and audgrnd
the pins are mic, mic power and ground.
didn't think a mic needed power.

anyway, thats the only wires out of place.

  Stuartli 21:24 22 Nov 2006

>>the only other differnce is the old one didn't have a switch, the new one does.
but thats good coz i get bored with the little red power light being on all the time at night.>>

Are you sure that the PSU is actually switched on?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?