new PC won't start with printer/D-Link plugged in

  bobbyalec 20:21 23 Dec 2013

Hi, and thanks in advance for advice offered, I got a new desk-top PC with Windows 8.1 installed and plugged in my printer, D-link modem and a separate hard drive with files I had saved for the new PC. I started it up and it seemed to be OK, then it said "Error loading OS" and shut down. I tried unplugging the accessories and it worked OK, and I could then plug in the rest of it and everything worked OK, but every time I shut it down and come back to it with the accessories still plugged it won't start up again and I have to repeat the process which is not an ideal situation!

The printer is an Epson WF-2010, the hard drive is a Seagate unit.



  Ian in Northampton 20:46 23 Dec 2013

It sounds as if it's trying to boot from your 'separate' hard drive. Is that an external USB drive? It could be that the BIOS is set to boot from USB first. Can I suggest trying to boot it with only your printer and modem plugged in? If it boots, that identifies the 'other' drive as the problem. If that turns out to be the case, you may want to look in the BIOS and change the boot order. If you're not comfortable with that, I'd take it back to where you bought it from and explain the problem, and get them to fix it

  woodchip 21:52 23 Dec 2013

As above, check BIOS Boot Settings. Set CD as First Boot then Hard Drive set other to none./ You can change these later if you wnt to boot from USB etc. I suggest you also stop Windows Restore on other than Main Operating System Partition. This will also make for faster Boot and Shut Down

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?