New laptop can detect wireless but not connect

  Tamburlaine7 09:05 10 Apr 2010

Hi guys. I have just bought a Toshiba Satellite L500-1XD but can't connect it to the internet. There's no problem in detecting the wireless signal but it can't actually connect.

It seems not to be recognizing the network password, but I've checked and it is definitely correct. I tried using the network trouble-shooting device and eventually just got a message saying "problem with wireless adaptor or access point". I've also tried rebooting the router as it is sometimes unreliable, but that hasn't helped - and my landlord has a PC running off the same router which isn't having any connection problems at all.

I'm not exactly a model of competence when it comes to this kind of thing - any help would be greatly appreciated!!

  Newuser3443 11:45 10 Apr 2010

Are you displaying your SSID (network name) in your router settings or do you have it hidden?

  Newuser3443 11:46 10 Apr 2010

Are you displaying your SSID (network name) in your router settings or do you have it hidden?

  Tamburlaine7 14:49 10 Apr 2010

Ermmm... I don't know how to find that out - would you mind giving directions?
In case it makes a difference, I should mention that my last laptop was connecting to the router without any problems. The laptop was on the verge of death so I used the Product Recovery disc as a last resort. That partly brought it back to life, but it couldn't connect to the wireless anymore after that. I assumed this was probably because the laptop was broken (other things were dodgy on it as well), but I don't know for sure that it wasn't a similar problem. (I was assuming not since the wireless had been fine up until that point though).

  mgmcc 18:14 10 Apr 2010

What type of encryption is being used in the router?

Some wireless adapters don't like an ASCII WEP key and will only connect if a Hexadecimal key is used. If the encryption is WEP, you can tell whether it is ASCII or Hex by the number of characters:

64-bit WEP uses 5 ASCII or 10 Hexadecimal characters.

128-bit WEP uses 13 ASCII or 26 Hexadecimal characters.

As far as the router broadcasting its SSID is concerned, you said initially that "There's no problem in detecting the wireless signal". If your adapter can see the SSID (network name) then the router *MUST* be broadcasting it.

  Newuser3443 21:29 11 Apr 2010

To clarify what I meant about the SSID, mine is being hidden by my router as an added level of security. To be able to connect (I'm using XP home) I have to go into Control Panel > Network Connections > Wireless Network Connection > Properties, Click on the Wireless Networks tab > Properties.

Under Network Name (SSID) 'Connect even if this network is no broadcasting' is turned off is unchecked by default. It needs to be checked on if the SSID is being hidden by the router.

  Tamburlaine7 10:27 12 Apr 2010

Hey, thanks to both of you! I now have it working - I took the laptop into the room where the router actually is (so that I could access the PC in there in order to follow both of your suggestions) and for some reason instead of asking for the security password, this time it gave me an alternative of entering a router pin number. The password still wasn't working so I tried using the most likely 8 digit number from the bottom of the router and this worked - although why that would work when it wouldn't accept the password (which was correct), I have no idea!

I've now discovered that even though the laptop can detect the wireless signal just fine when it's sitting on my usual workspace in my room, it can only connect when I'm in another part of the room. Which is inconvenient and seems a bit weird, but it's an improvement at least. Any suggestions on whether there's anything I can do about that, feel free to let me know!

Thanks for all your help.

  mgmcc 12:34 12 Apr 2010

Possibilities are:

- in your "usual workspace" something like a mobile/cordless phone or other electrical appliance is interfering with the signal.

- there is a large metal object, such as a filing cabinet or central heating radiator, in the "line of sight" between router and Laptop.

  proudfoot 17:04 12 Apr 2010

I had a similar problem with my wife's laptop, it would not connect to our router although my PC in the same room could connect.

I accessed the router and changed the wireless channel. Problem solved

  Tamburlaine7 10:55 13 Apr 2010

Ok, thanks guys. Just to confuse matters further, the problem wasn't solved at all even a little bit - the wireless dropped out again completely (even when I'm literally sitting the laptop next to the router) and I haven't had any luck reconnecting since.

I think I may have found the problem though - on the Windows website for checking whether specific routers are compatible with windows 7, our router isn't listed as one of the compatible ones with my processor. So I may have to look into getting a different router and see if that fixes it.

St-clares, how would I go about changing the wireless channel? And is there any risk to doing so? (I am in a slightly sticky situation in that the router and the other PC both belong to my landlord and hence I have to be careful that I don't risk messing anything up!)

  proudfoot 15:46 19 Apr 2010

You will have to access your hub by entering it's URL, enter your password, enter Wireless Setup and this should take you to a page where you can change the wireless channel.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?