New home build "map: cannot find required map name"

  Bill8 14:47 27 Apr 2013

EFI Shell Version 2.31 [4.633] Current running mode 1.1.2 Map: Cannot find required ma name

Press Esc in 5 seconds to skip startup.nsh, any other key to continue

shell id>

The message above is what i get after the flash screen. Nothing happens if i press Esc or any other key to skip the "startup.nsh it just finishes the count down faster. If i type "exit" it sends me to the bios menu. I have made the HDD primary start up but still nothing. The DVD drive doesn't run the motherboards CD.

I installed the below replacing the old parts. Crucial BLT2CP2G3D1608DT1TX0CEU Tactical 4GB kit (2GBx2), Ballistix 240-pin DIMM, DDR3 PC3-12800 Memory Module

Intel Core i3 2125 3.3 GHz Processor with Socket 1155, L3 3Mb, Sandy Bridge, 32nm

MSI Z77A-G43 Motherboard (Intel Core i3/i5/i7/Pentium/Celeron, Intel Z77, ATX, RAID, Gigabit LAN, Socket LGA1155)

Im at a loss, need help please.

  csqwared 19:40 27 Apr 2013


Googled startup.nsh and came up with a PDF (among other things) which suggests you might need to alter a BIOS setting. I've reproduced what I think is relevant below but haven't managed to properly copy the link, can't capture the full address. If you Google, on my results page it came 8 down in the list of hits and begins "[PDF] Basic Instructions for using EFI (EFI.........

Hope this helps.

"*To boot to the EFI shell, press F2 when prompted during POST to enter the BIOS utility. Within the BIOS utility, arrow over to the Boot Devices option and press . Then scroll down and highlight the EFI Shell option. Press to go directly to the EFI Shell.*

*The EFI shell can be set as the first item in the Boot Order Menu so that the system always boots into EFI. (By default, the EFI shell is the last item in the Boot order option list.) Simply enter the BIOS utility (F2) and arrow over to Boot Options and press The highlight the first option and press and arrow down to the EFI Shell option and select . Then press F10 to save this as the new boot order.*

*Upon booting to the EFI shell, the embedded OS will always look for a file named startup.nsh (searching through the “path” defined). Startup.nsh is the equivalent of autoexec.bat in the DOS/Windows environment. After running this startup script (if found), the user will be presented with the command line prompt Shell>.*"

  csqwared 19:47 27 Apr 2013

Another suggestion I've come across...

"go into the BIOS and selecting "Reset to Optimized Defaults" or whatever your particular MB has. Could be "Factory Default Settings".

  csqwared 19:56 27 Apr 2013

and there's more....

"In 2011 ASRock, ASUSTeK, Gigabyte Technology, and MSI launched several consumer-based motherboards using the Intel 6-series LGA 1155 chipset and AMD 9 Series chipset for AM3+ AMD FX (Bulldozer) and AMD Fusion processors with EFI.[36]"

  Bill8 20:05 27 Apr 2013

Thanks for the reply, tried finding the pdf you were talking about but the only one that was 8th down on the list was the link below;

Once i make Startup.nsh my first boot priority what do i type in the command line prompt after to get in my system. The HDD already has an OS installed.

I don't get your last post?

  csqwared 11:15 28 Apr 2013


Last post was merely to point out that your mobo/CPU appears to have EFI by default?

You say the HDD already had an OS installed. Was the HDD second hand and which OS?

I presume you are trying to boot to the original OS (Win XP/7/8) in which case I would try the suggestion of "Restore to Factory defaults". I have no knowledge of this EFI system apart from what I've gleaned from 't'internet. There's shed loads of stuff regarding EFI, in the main quite confusing.

I did mislead you slightly by saying 'Googled'. I found the PDF using the browser and it still refuses to let me copy and paste link properly. I did find this however which may be of use.

Windows from EFI

Hopefully someone with more knowledge of the subject will pick up the thread.

  Bill8 11:44 28 Apr 2013

Generic Hard Disk Drive 500GB SATA II - by Generic. Its my old HDD everything is already installed on it with Win 7 ultimate as the OS 32 bit (not 64bit).

Tried the restore option without any luck.

If it is EFI that is causing the issue can't i just disable it.

Thanks for helping CSQwared your about the only one replying to this thread and iv cut and pasted this issue in several forums.

  Bill8 11:46 28 Apr 2013

Forgot to mention on the bios it doesn't see the harddrive either. So could that mean there is something wrong with the hdd?

  csqwared 12:13 28 Apr 2013

I would think if you have a correctly functioning HDD the BIOS should see it.

I've had a quick look at the manual for your mobo and it suggests ( page2-3) you should be able to downgrade the EFI (called UEFI) to the end of the boot list, but if your HDD is not visible that won't work.

My thought would now be, if the HDD is not showing in BIOS, check all connections and if OK, to try another HD. I suppose another option would be to get a mobo which doesn't use EFI.

Can't find anything on the web regarding disabling other than in BIOS.

disable efi

  csqwared 14:12 28 Apr 2013

Another thought occurs to me here, just to make your life a little easier :-((

If you are trying to use your old HDD with an installed Windows operating system on a system with a new mobo and memory you may have to do a clean install of the OS or at the least, reactivate Windows. If I remember correctly, Widows has a 'count up' system of new hardware and if you exceed a certain value (??) you need to reinstall/reactivate. Been doing a search but can't find the precise details. If you have an OEM version you might have a problem.

  csqwared 14:21 28 Apr 2013

This is the nearest I can find:-

"Re: Install old hdd to new motherboard. You can't do that. Windows serializes all of the hardware on the initial installation. Minor changes can be made, ram, hard drive, CPU, etc. A motherboard is a complete change as far as Windows is concerned.

This isn't a simple matter of removing drivers and installing new ones.

You will need to reinstall Windows. As always, ensure you have your data backed up."

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S10 review: Hands-on

From Haiku to Hokusai: How a new puzzle game was inspired by ancient Japanese art

Best free iPhone games 2019

Les meilleurs forfaits mobiles à moins de 20 €