NEW HIGH END PC USED TO RUN FAST, BUT NOT ANYMORE

  Razvan Banescu 16:20 02 Mar 2018
Locked

Hello,

I have a pretty frustrating problem. I just bought this PC:

  • Intel Core i5 7400 3.0 GHz

  • Nvidia GeForce 1060 6 GB

  • Mother board MSI 110M ECO

  • 8GB RAM

  • 1TB HDD

  • 240GB SSD KINGSTONE

  • 520W Source, forgot the manufacter

I first had windows 7 put on it but because the windows was too old, it wouldn't function well with the graphics card and I would get screen tearing. The video games were running just fine though. I upgraded to windows 10 and after playing a game like CS:GO I noticed that I had like 300 FPS, which was very good. I then closed my PC, went to sleep and noticed the next day the maximum frame rate I was getting was like 150 FPS, which wouldn't be bad at all, if i did not get sudden frame drops to like 40-50 fps. I then tried other games and noticed that in all of them my frame rate was lower than normal. I then wanted to play Insurgency, a very old game that should run very good and I cant even get 50 frames. I tried everything possible and now I'm scared that there is a problem with my mobo, even though the PC is 3 days old.

The only thing I have in mind is that maybe the source or the cooler needs a replacement, because the PC has the Intel stock cooler, but after all it's new so this shouldn't be a problem.

(I considered everything, I troubleshooted everything, please help me).

I'm frustrated because I dreamed for this computer a lot and saved all my pocket money on monthes.. The worst part is that because I added the SSD i dont have any warranty on anything!

Please help me! I don't know what to do. I really hope it's not something wrong with the components! At first it worked so well and i was so happy to know i spent my money well, and then.... Help me please, thanks.

  Secret-Squirrel 18:01 02 Mar 2018

The first thing to try when a Windows 8/10 PC plays up is to restart it. Shutting down and turning the PC back on will have no effect. Click the Power button and choose Restart.

  Razvan Banescu 18:08 02 Mar 2018

I restarted it several times because I also tried reinstaling some drivers in search for a solution.

  rdave13 21:12 02 Mar 2018

What security software do you run?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei Mate 20 Pro review: In-depth hands-on

See concept art from groundbreaking video games including The Last of Us, Journey and No Man's Sky

iPhone XR release date, price & specs

Les meilleurs VPN pour Kodi (2018)