New Hardware Detected - unknown device

  Sben 10:23 06 May 2004

When I first log on and also when I first connect to the internet I get a New Hardware Detected message and the Add New Harware wizard starts.
The wizard states 'Unknown device'.
If I cancel the wizard the system continues as normal. If I start to use the wizard and then cancel an 'Unknown device' is shown in my device manager (start - control panel - system)

Any Ideas?

  johnnyrocker 10:30 06 May 2004

what happens if you right click in device manager the object and select properties? does it identify it then?


  Gongoozler 10:39 06 May 2004

This sounds to me like a modem driver not properly installed.

  Sben 10:42 06 May 2004

The device description is 'Unknown Device' in a new category called 'Other Devices'.
The properties for the 'Other Devices' category states '? Other Devices'
The properties for 'Unknown Device' states:
Device Type: Other Devices
Manufacturer: None Specified
Hardware Version: Not Available

  Mat2 10:51 06 May 2004

This may help you identifty the unknown device

click here


  Sben 11:09 06 May 2004

Mat2 - I have tried the utility suggested but when I run it it brings up an error dialog stating Invalid Level (5) for item ""

  Tog 11:13 06 May 2004

Do you have a PCI modem fitted? This is a common problem with these as Gongoozler has pointed out.

If it is, then check you have the driver disk and uninstall/reinstall.

  Sben 11:23 06 May 2004

The modem I have is a 'Creatix V.90 HaM Data Fax Modem' which I beleive is a PCI modem (integral with computer when new). I have clicked on this device in the device manager & re-installed the driver (from back-up files on hard drive).
The modem has allways worked OK (used for faxes) - internet connection is broadband.
The 'Unknown device' is still here.
Any Ideas?

  Gongoozler 11:49 06 May 2004

Modems can be very fussy about driver installation. You could try removing the modem, then delete both the modem and the "unknown device". Reboot the computer and if it doesn't try to reinstall the unknown device you'll know you've found the right one.

Then reinstall the modem strictly in the sequence instructed by the manufacturer.

Another possibility is that the motherboard has an integral device (such as LAN?) that hasn't had its driver installed.

  Tog 11:53 06 May 2004

My PCI modem would always do this when I installed it incorrectly. It would never install correctly except from the original CD and the installation wouldn't take unless previous attempts were completely uninstalled first. Try the Creative website for the latest drivers for it and go from there.

  Sben 11:58 06 May 2004

Thanks Tog & Gongoozler I will try removing & re-installing the modem later - too busy now.

I'll let you know how I get on

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)