Networking Permissions Problem

  Rockarch 09:51 10 Jan 2005

In networking my laptop (XP Home SP2) and desktop (XP Pro SP2) I am being driven mad by the following problem: on the desktop I can see the laptop shared files & copy to & from so all works fine. On the laptop the connection obviously works because I can access the web via the laptop but when I try & browse the network I get the following message:
'Whitecroft [network name] is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Windows cannot find the network path. Verify that the network path is correct and the destination computer is not busy or turned off. If windows still cannot find the network path, contact your network administrator'
I have rerun the network set up wizards, changed the network name, created new users on both pcs and changed every permission I can find but its always the same message.Both PCs have Norton AV 2004 but even with that switched off its still the same.
Can anyone help??

  spikeychris 11:50 10 Jan 2005

Assuming you have disabled any firewalls [as this is an error you would get if one was activated] check event viewers on Both machines, does one say "Event ID 2011"?

  Rockarch 12:46 10 Jan 2005

Thanks. I've checked event viewers on both machines and there is no 'Event ID 2011'.
The only firewall is the windows one which I assumed would configure correctly for networking when I ran the network setup wizard.
The problem appears to be with the laptop as it also gives me the same error message when I try and connect the my office network .
Any other ideas?

  spikeychris 14:07 10 Jan 2005

If you haven't disabled the firewall [built into SP2] the do so. The Event ID 2011 relates to Norton AntiVirus, even when it is switched off it has caused problems with networks. Check HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters. In the right pane, double-click the IRPStackSize value, its default value is 15, whats yours? If its less, type 15.

click here for related info.

Before you do the above enable NetBIOS Over TCP/IP

Open Network Connections

Right click the local area network connection and click Properties.

Double click Internet Protocol (TCP/IP).

Click Advanced.

Click WINS.

Click the Enable NetBIOS Over TCP/IP button.

Reboot and open my network places, wait a while to see it it finds it.

  Modo 16:24 10 Jan 2005

2011 is normally connected with having a large number of computers and users on a home network and it usually hits the one that is acting as a "server" in terms of controlling printers etc. Depending on number of users it normally only becomes a problem with about computer 4 or 5 on a Home Network (XP or Home edition).

It doesn't sound like it is your problem - unless your laptop is allowed to access several other shared folders on a network elswhere.

(Also the Windows Knowledge Base on 2011 dates back to Dec 2003 and applies to NT4.0. It still applies but you may find that in the Registry under LanMan server in HKLM no referfence exists to IRPStacksize at all. In which case you have to start creating it. This is getting a bit serious even if you know reasonably what you are doing!!

9 times out of 10 this problem is a Firewall issue. Can you recheck the Windows Firewall by going to it through Control Panel. Click Advanced and just make sure it isn't on for your Wireless connection.

Let us know.

  Modo 16:31 10 Jan 2005

Having read again, it may be 2011

"The problem appears to be with the laptop as it also gives me the same error message when I try and connect the my office network"


The server is configured with too many file system filter drivers (for example, Quota and anti-virus) and/or too many devices, or the irpstacksize parameter is set to less than the default of 15 stack frames. The irpstacksize represents the number of kernel modules that can store information in the input/output (I/O) Request Packet (IRP). The IRP is used to track I/O requests in the kernel.

  Rockarch 17:29 11 Jan 2005

Ok - this is all getting a bit serious!
I did not have an Event ID 2011 in the first place!
Trying out the various suggestions:
I checked the IRP stacksize and is it 4294967292 in decimal (whatever that means)
NetBIOS over TCPIP was already enabled in network connections.
Disabling the firewall makes no difference.

My laptop is allowed to access multiple shared files on the office network but its the same problem that while other computers on the network can see it, the laptop itself denies permission to the network.
My home network is only 2 pcs linked by a direct cable.
Any other ideas what next?

  mrdsgs 17:43 11 Jan 2005

have you got the same username on both machines and the same password?

if not, try adding the pcs username and password to the laptop and vice versa. you can hide them later.

this worked for me with identical symptoms


  spikeychris 18:11 11 Jan 2005

If the above solution from mrdsgs doesnt work then log in to the Pro machine and...

1. From Run type "secpol.msc" and hit enter

2. Click Local Policies.

3. Click User Rights Assignment.

4. Click "Access this computer from the network" and make sure that
the Everyone group is included.

5. Click "Deny access to this computer from the network" and make sure
that the Everyone group is NOT included.

  Rockarch 18:43 11 Jan 2005

Curiouser and curiouser - checked the desktop (Pro) & correct assignments as you describe, however when I type 'secpol.msc' into 'run' in the laptop (Home), I get the error message 'Windows cannot find 'secpol.msc' ???
Does the file not exist in XP home or is there some other means of accessing the user permissions?
What next?

  spikeychris 18:49 11 Jan 2005

For the Home machine you would have to take a different route as secpol.msc is not available....

1. Download and install the Windows 2003 Server Resource Kit Tools
from click here .

2. Click Start | All Programs | Windows Resource Kit Tools | Command

3. Type these lines at the command prompt. The second and third
commands are case-sensitive, so type them exactly as shown. Note the
"+r" in the second one and the "-r" in the third one:

net user guest /active:yes

ntrights +r SeNetworkLogonRight -u Guest

ntrights -r SeDenyNetworkLogonRight -u Guest

But thats not the issue here though....

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?