Network not assigned network address.

  User-1159794 12:26 22 Sep 2007

Removed some spyware and a virus recently from a PC.Then added a couple of anti malware programs to the PC,updated all and handed the PC back.

A week later he tried to go online,the first time since getting the PC back and found he could not.He got in touch with Virgin and they came with another modem,but said the fault was with the PC.

He brought the PC back up to me, I plugged it in to my Linksys router,no problems.

I gave him a usb cable to try,but he is getting the Error: "Limited or no connectivity. You might not be able to access the internet
or some network resources. This problem occurred because the network did
not assign a network address to the computer".

He is using Xp media edition with all updates.and the modem is a Scientific Atlanta. Webstar 2000.

I feel that I have missed something simple somewhere. Some setting or other.

Thanks for any help.

  mgmcc 19:20 22 Sep 2007

Is he definitely connecting to the Cable Modem by ethernet and not USB? If so, he should get the IP address from Virgin's DHCP server in exactly the same way as he got it from your router.

He could try opening a Command Prompt window and running the commands:


and then:


  User-1159794 08:12 23 Sep 2007

He has tried the Ethernet connection but on the advice of another Friend who is with Virgin and uses the same modem he tried the usb connection.
Windows sees the modem but unfortunately displays the above error.

I will try the commands you have suggested.


  User-1159794 08:46 24 Sep 2007

Any other suggestions folks.

  ambra4 17:34 24 Sep 2007

see if this work

Go to this site and download the following items

New 2000 series USB driver,

Complete Scientific Atlanta Cable Modem Installation CD

And the updating USB driver on Win XP Instruction

click here

  User-1159794 07:54 25 Sep 2007

Thanks for that,definitely worth a try.

  User-1159794 18:38 28 Sep 2007

I have with the help of a friend who also uses Virgin and that modem,found that the fault lies with with his connection,either his phone line or even from Virgin themselves.

thanks all.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique