Netgear Wn111 does not run at full speed

  pmar2uk 14:25 25 May 2010

I have a WN111 Netgear adaptor(USB) running on my Xp laptop which runs at anything between 120 -300 mbps connecting with a WNR200 N class router , i am very happy with the speed .I have now added another laptop to the wireless and so i thought to bring me up to speed i would add another wn111 v2 adaptor to bring that laptop up to 300mbps networking as well .Whatever i do i cannot get the 2nd adaptor to run past 54Mbps (the 300mbps option is checked when i look) the only difference between the two laptops is the 2nd one is running Windows 7 and the first(where it is running at 300mbps) is XP .Could anybody enlighten me please why this is happening,

  mgmcc 19:53 25 May 2010

Are you definitely using *WINDOWS 7 DRIVERS* with the adapter?

  pmar2uk 20:19 25 May 2010

I have since had a crisis of my abilities and reloaded drivers and also swopped adaptors about to see if i had been sent a G rated adaptor , but the swopped adaptor worked fine on my XP machine and then went back to 54mbps on the windows 7 machine .One thing to note is am running the 64 bit version of windows 7 but i checked on the netgear website and it says for 32 and 64 bit ,


  mgmcc 20:47 25 May 2010

I have an Edimax 802.11n (150Mbps) adapter which connects at 150Mbps in Windows XP, but only at 54Mbps in Windows 7 64-bit. This isn't a problem for me because I have another adapter to use with Windows 7 that does connect at 300Mbps.

It does, however, indicate that there may be a problem with some adapters only connecting with 802.11g (54Mbps) protocol when used in Windows 7.

My adapter that does work at 300Mbps in Win 7 is a "D-Link DWA-140 RangeBooster" click here in conjunction with a D-Link Router.

  pmar2uk 20:47 25 May 2010

I have now solved the problem .Please note all other users that you might have to upgrade to WPA2 encryption as even on WPA the adaptor would only tun at 54mbps , as soon as changed to WPA2 it went straight to 300mbps ,starnge but thats how it is , thanks for all help


  mgmcc 22:35 25 May 2010

I'm actually using WPA2, but my Edimax 802.11n adapter still only connects at 54Mbps in Win7.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?