Netbook won't connect via Homeplug

  dms_05 09:03 12 Jun 2010

I've just bought a couple of 85MB/sec Homeplug adaptors and they work fine with a desktop and a laptop but when I try them with a Netbook (MSI Wind) I can establish a LAN but not connect to the Internet. The desktop/laptop connect via DHCP and worked immediately. The netbook fails using DHCP and I've tried setting a static IP adress (192.168.0.xx range, Submask and Gateway This establishes a LAN but will still not allow me access to the Internet, so I tried DNS as (default) and Open DNS but that didn't help.

I'm now connected with the Netbooks WiFi without a problem using auto IP and DNS.

Any suggestions why the Netbook seems to be throwing up a private network ( with submask when LAN cabled but works OK when in wireless mode?

  dms_05 09:14 12 Jun 2010

I should add that I'm using XP SP3 and if I connect the Netbook directly to the router with a LAN cable it connects and I can access the internet using auto DHCP. It's only when I use the Homeplug/Powerline connection I have problems.

  dms_05 09:48 12 Jun 2010

And with the Homeplug LAN showing 'Connected at 100MB/sec' I can't access my router using

I've tried turning the XP Firewall OFF and that makes no difference.

  hartt 16:30 28 Jun 2011

I had the same problem too and contacted Homeplug UK. They advised plugging the netbook into a socket where you know the homeplug works (where the desktop and laptop are operating from), also try swapping the homeplugs. I was told that there are sometimes spots on domestic wiring circuits which do not work for some reason.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Explore Milton Glaser's iconic poster designs from the 1960s to present, including Bob Dylan, I…

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts