Need help with another printer issue!

  fedex1969 13:21 15 Jul 2012

Hi,again, Guys. Having purchased my new pc a couple of weeks ago, I have since been connecting peripherals ect. to complete the set-up. Having connected the printer, HP Deskjet F4580, and downloading driver from HP, stupidly, I didn't bother to test it. Having tried to print from it just now, a Scrip Error box appears. The text in this box is as follows: ! An error has occurred in the script on this page. Line: 2126 Char: 1 Error: Unspecified error Code: 0 URL: res://ieframe.dll/preview.js

Do you want to contiue running scripts on this page? Yes/No

I have no idea what this means or how to fix this. Any ideas? Thanks in advance.

  Nontek 13:50 15 Jul 2012

I would suggest uninstalling the printer and then re-installing it and make sure you follow the procedure exactly - by that I mean some printers will let you know when, or if, you need to connect it to PC during the installation.

If you are using the printers own CD for the installation, you should then update the software via the HP website.

  fedex1969 14:29 15 Jul 2012

I tried what you suggested but the same error message appears. Anymore ideas? Hate it when things don't work properly.

  Nontek 14:40 15 Jul 2012

click here

You might find the solution here, scroll down a bit to see what worked for someone else.

  fedex1969 16:21 15 Jul 2012

Thanks for the response, Nontek, but I don't even understand whats being said, let alone put into practice. I'm a bit of a Noobie.

  difarn 16:36 15 Jul 2012

You may find this article from Microsoft with suggested steps a little more straightforward.

  chub_tor 16:39 15 Jul 2012

Reading Nontek's link the common solution seems to be the following "regsvr32 ole32.dll"

If you have Win 7 all you need to do is to click on the Start Orb and type that command into the Search Box that appears (make sure that you have a space between the end of regsvr32 and ole32.dll) then hit Enter.

The command should run and hopefully say that the dll has been successfully registered.

If you have XP then you need to use Start, Run and type the command in the Run Box.

Let us know if it works.

  fedex1969 18:04 15 Jul 2012

chub_tor, that didn't work. difarn, not having much luck there, either. I can print from Word, just not websites, if this makes any difference.

  chub_tor 20:59 15 Jul 2012

When you ran it did you get the message that ole32.dll had been successfully registered?

  fedex1969 19:00 16 Jul 2012

chub_tor, sorry for the delay in my response. Upon entering that command, the following diologue box showed: The module "ole32.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070005. For more information about this problem, search online using the error code as a search term. Hope this means more to you, as I haven't a clue. I haven't searched online with this code, either. Should I?

  chub_tor 22:05 16 Jul 2012

Microsoft Answers gives the reason for the failure as follows. It suggests that you are not logged in as an Administrator when you are trying to register the DLL. Are you registered as the Administrator of the PC with the problem? If not you can always create a new Administrator account and try again.

*This behavior may occur if you try to register a DLL by using Regsrv32 while you are logged on using an account that does not have administrative credentials, such as an account that is a member of the standard users group. An account that does not have administrative credentials cannot write to the registry or change files in the System32 folder.

*RESOLUTION To resolve this behavior, log on by using an administrator account, and then register the DLL.**

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Visual Trends 2018: This year’s must-know colour, design, branding & photography trends

iMac Pro review

Apple Music : comment obtenir 3 mois gratuits ?