NAS connectivity issue on local network

  Odberatel Funney 17:00 05 Aug 2018

So I have this NAS - Asustor AS3204T. For a while there were no problems, I set it up quite easily and I was running it for six months without a problem. All of the sudden it started acting up on my home computer that runs Win10.

For a few weeks I could find the drive on the network only if i restarted the NAS. It wasn't that big of a problem until one night i decided to "fix" it. One of the suggested solutions were to revert to SMB1 connection, so I ordered the NAS to take maximum of SMB1, ignoring the second and third. This made the drive totally invisible on my network. So I have reverted the settings. But the problem persisted.

Now I've been trying solutions from all over the internet. At first I have focused on Samba related fixes (it seems that I'm not the only one this type of problems, especially on Win10 machines), network visibility and connectivity fixes, also turned off the Blacklists on the NAS, tried turning off Windows Defender and antivirus... well most of the basic stuff I guess. After six hours of searching and trying, I'm stumped as to what the solution is.

The NAS works fine in online browser and through mobile apps. It seems only my main networked Win10 is affected, and seems more like a windows problem than a router one.

The weird thing is that I found out that the NAS is findable through direct search (as in \AS3204T-FEDC), but the root is invisible to the user. When trying the second level (as in \AS3204T-FEDC\Work) it gives me the basic network error (0x80070035). When I try hard enough (as in try to connect for a few minutes) in the end it will let me enter my credentials and log in. What the hell Microsoft. Also after I once log in, I'll stay that way until reboot.

Its all documented in this video click here . Please bear with me, the nature of the problem means the video is six minutes long even after speeding it up.

TL:DR -

I have Asustor NAS AS3204T, my windows 10 saw it just fine on local network for a few months. Now it stopped working and I can find it only after few minutes of unsuccesfull clicking as seen in this video.

Connection from other devices works just fine, the online and mobile browser also work. I tried all the basic stuff like switching off antivirus, win defender, restarting NAS. Please help me.

  alanrwood 17:55 05 Aug 2018

Microsoft know there is a problem with networked machines not displaying in File Explorer after the 1803 update. They can still be accessed by typing the machines local IP or path. I managed to sort my network out by installing a couple of Windows items but one was SMB1 which I am advised is not a good idea.

  Odberatel Funney 18:34 05 Aug 2018

mrcalif - Thanks for replying. I have tried enabling and forcing SMB1, which ironically caused current issues. I have since reverted these settings back and currently using max SMB3. The issue described in the video I posted is not influenced by SMB one way or the other. It still takes few minutes of trying to get the log in popup.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Red Dead Online release date and gameplay news

Create a glowing superhero

Mac mini 2018 review

Les meilleures prises CPL