My Windows Boot Manager is gone!

  drpeppercan 05:23 27 Aug 2018

Hi all! I am setting up a dual boot system (Win10 & Ubuntu) in a 2 year old desktop pc. I had Windows 10 reinstalled just a couple days ago In my 1 Tb HD. Then I installed Ubuntu in my 120 Gb SSD. Then Grub was not found, so it would boot straight to Windows 10. Which I was expecting. Then I disabled fast startup in Windows 10, I forgot to disable fast boot in UEFI settings. I can't do the latter now because WBM is not available to boot from. Then I used bcdedit to set a new entry for Ubuntu: bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi (I can't recall where I got it from, but here they have a very similar tutorial[/link]). I had used this trick before and it worked. Then I rebooted, but instead of showing me Grub, it was a black screen with two lines of text: Reboot and Select proper Boot Device or Insert Boot Media in selected device and press any key. Then I went in the BIOS, and that's when I no longer saw Windows Boot Manager as an option! I booted off from Boot Repair Disk, and supposedly fixed Grub, but I still can't see WBM, and even though I do see Ubuntu in Bios, it still yields the above line of text (Reboot and Select...). But BRD generated a report, here it is.

Presently, and temporarily, I am only able to boot into Ubuntu or Windows 10 as long as I first boot off from a rEFInd Live USB drive. The rEFInd finds them both and allows me to choose.

Hopefully the BRD report can help you to see what's going on. The way I see it, I need to either remake/repair the MBR for Win10, or have it in the right disk. Something along those lines, I guess.

Thanks in advance!

  drpeppercan 16:29 27 Aug 2018

It's all good now! I just booted Win10 with Shift, then I went to Advd ops/Start-up Repair (Fix problems that keep Windows from loading). Strangely it said it was not successful. Then I went to UEFI Firmware Settings, but when I clicked that choice it only had a Restart button available. It brings you to the BIOS. But once there, in the Boot Options tab, there was nothing that would allow me to turn off/on Fast Boot. Windows Boot Manager was nowhere in sight still. Then I restarted, and Grub showed up! Along with the Windows choices too. So I no longer need to boot from the rEFInd USB drive.

I will have to find out for the next time, where should I tell Ubuntu to install the booting files? Assuming Windows has been installed already, and I'm installing Ubuntu on a separate drive.

Thanks guys!

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Huawei Mate 20 Pro review: In-depth hands-on

See concept art from groundbreaking video games including The Last of Us, Journey and No Man's Sky

iPhone XR release date, price & specs

Les meilleurs VPN pour Kodi (2018)