My PC crashed 3 times last night ....

  stlucia 08:42 18 Oct 2008

... twice with a blue screen error message, and once with random characters all over the screen. Each time it re-started okay after I powered down at the mains.

The blue screen messages contained the following lines, which I hope are the relevant ones:-


and, near the bottom of the screen:

**** USBPORT.SYS - Address F7AC24A7 base at F7ABA000. Datestamp 480254ce

Do those messages tell me what has failed, please?

The PC is an Evesham with an Athlon 600, and is about 9 years old. It has its original USB1 ports and a more-recent PCI card with four USB2 ports. It has four HDDs totalling about 500Gb (can't remember exactly), and 5Mb of memory. Is more info needed, or is there enough there to say whether it can be cheaply fixed or needs to be totally replaced?

  FatboySlim71 09:05 18 Oct 2008

When did you install the "more-recent PCI card with four USB2 ports"?

Also have you installed any new hardware recently?

  Zeppelyn 09:05 18 Oct 2008

Seems like you have a dodgy USB Driver. Double check your new PCI card is properly seated in its slot. Also I would go to Device Manager and unibstall all drivers listed under Universal Serial Bus controllers and reboot pc, Windows will then reinstall them. Problem may also be caused by one of your USB devices.

  FatboySlim71 09:06 18 Oct 2008

What operating system are you using?

  stlucia 09:10 18 Oct 2008

The "new" PCI USB2 card was installed earlier this year -- I don't remember exactly, but say six months ago.

Are those error messages telling me it's definately USB related? I'll uninstall the USB drivers and let Windows reinstall them, as suggested.

None of my USB devices has caused any problem recently except, perhaps, my AOL/BT BB modem which has once or twice failed to connect properly. But I put that down to a BT or AOL problem, since it connected okay next day each time.

  mocha 14:08 18 Oct 2008

Hi stlucia,

It sounds like a memory fault. Download memtest86 and make it into a bootable CD.

Make sure your CD/DVD drive is 'First Boot Device' in you Bios, put CD in drive and restart computer.

Run the full diagnostics program. this will report any memory problem.

  woodchip 14:27 18 Oct 2008

I would say Memory or faulty Graphics card

  stlucia 21:04 18 Oct 2008

Tonight I switched on, and my PC failed to connect to the internet. I got a message about Windows has recovered from a serious error, and has disconnected the USB hub, or something like that. So I'm leaning even more towards USB card or drivers or USB modem as causing the problem. AOL Connect has connected via the USB BB modem at the second attempt.

The simplest potential solution is uninstalling the USB drivers, as suggested by Zeppelyn, so I'm going to do that now. But I feel I should make a restore point so I can recover if things go wrong. I've never used "Restore" before (Win XP with all SPs and updates), but I've just checked Control Panel > System Restore and it seems to say that it's automatically creating restore points, i.e. the "Turn off system restore" checkbox is not checked for any of my drives. So, before I start deleting drivers, how do I restore my settings if things go wrong, please?

  Condom 22:02 18 Oct 2008

If your PC is nine years old then its USB ports were USB1 as you say. I can see why you put a PCI USB2 card in but there are many other things which worry me. You have an Athlon 800 and 5 MB memory which might have been OK for Win98 but hardly sufficient for XP. You also say you have 4 hard disk drives. I assume you are also running a CD or DVD unit and all of this in a 9 year old computer. It must be severely straining its power supply. How it has worked to this day says a lot about the old Evesham company. In all honesty I really think it is time to invest in a newer PC and perhaps use your old one to try Ubuntu or some other Linux system.

  stlucia 08:53 19 Oct 2008

Condom ... believe me, I'm working on the missus about replacing it!! We're getting there (she asked yesterday how much a new one will cost without me prompting her about it) but for the moment I've got to keep this running.

It seems to crash after half an hour of running, which originally made me think of the PSU. But then the blue error message still on the screen made me realise the PSU was still providing power. The PSU was upgraded many years ago for a "heavy duty" one some time when I started putting in those extra drives.

  stlucia 20:11 25 Oct 2008

The problem has resolved itself: I managed to rebuild two of the USB drivers, as suggested, but the time between crashes was becoming shorter and shorter, and the BSOD message was a different one each time, until eventually my PC wouldn't even switch on.

So, it's been binned, and I've got a nice shiny new one. Problem solved ;-))

Thanks for the contributions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Les meilleures séries Amazon Prime Video (2018)