my ocz psu doesn't start up

  habs2habs 06:52 03 Feb 2010

hi everyone

i am writing this threat hopping will get help from you very soon.

yesterday 2/2/2010 i bought this (power supply) from ):OCZ MODXSTREAM-pro 700watts.

it was the first products i bought from this company.

i installed it in my pc(connect the main power for the motherboard,dvd-rom,dvd-writer,3 internal hard disks,1 graphic card,all the plugs are firmly fitted).

to my biggest shock,when i switched my pc on,nothing happened.

i unplugged all wires,and tried sit all the plugs again(maybe some plugs became loose),all the plugs were firmly seated.

i tried these 3 times,nothing worked.

on troubleshooting booklet,it said something about):
This is necessary to release the LATCH condition of the protection circuit.

-please where can i find that,and how to do it?

the old psu(400 watts) was working perfectly well,before replacing it with the new psu.

kindly can you please tell me what is happening,and how to solve this problem?

i hope to hear from you very soon.

My kindest regards

  crosstrainer 07:52 03 Feb 2010

The latch condition requires waiting 2 minutes according to the manual, then re-sets itself.

Try connecting bare essentials first. HDd and graphics card, if this works, add the other periperhals one at a time until the fault re-occurs. If this fails, I would return as faulty.

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?