Is my NIC broken?

  los252oc 02:29 02 Oct 2008

i just recently bought a new hard drive for my pc and installed windows xp w/sp3 but now that its all installed i cant get online, i tried various repair techniques to no avail, i dont know what to do... i get limited or no connectivity every time, my NIC shows up in device manager as all good, i even ran the broadcomm controller application and it passed all tests, when i plug my cord in the lights come on the same as usual, but if i disable my NIC then enable it, it just starts aquiring ip then the x shows up,and the light in my ethernet port turns on and off and it just repeats this process over and over until i take out the cable and put it back in then i get the limited or no connectivity thing, i'm thinking my NIC is going bad because the cable works in the pc i'm using now just fine, and before the hard drive install and windows xp install the pc worked fine, oh and when i try to get online and do the network diagnostic i get the "Error attempting to validate winsock base providers:2 ...well before i go buy a new NIC i was lookin for some help if there is any

  ambra4 03:56 02 Oct 2008

Re-installed the LAN card driver

And check the LAN card configuration and the network setting to allow you to access the Internet

click here

  los252oc 05:18 02 Oct 2008

i did all that but it didnt work, if this helps, the pc i'm on now works fine, when i do ipconfig /all on this pc i can see the dns suffix list as whatever at but when the other pc is hooked up i cant even see that, it has no dns info at all, but i get no info of the adapter being faulty from anywhere, its recognized in ipconfig and everywhere else on the pc as ok, but something is wrong

  mgmcc 07:42 02 Oct 2008

I know you've installed SP3, but see if this article about the "Limited or No Connectivity" error after installing SP2 is relevant click here

  zarobian 08:00 02 Oct 2008

First of all reset your Winsock,as under:
Run-type cmd ...hit return;
Type> netsh Winsock reset....hit return
This will reset your winsock.
For a DNS error type: ipconfig /flushdns...hit return.There is a space between ipconfig and forward slash.
You will have to restart your computer.

Good luck.

  los252oc 01:27 03 Oct 2008

i tried all the above guys, with no success, i even set up my 2 pc's side by side, plugged in the ethernet cord and got right online with the pc i'm using now, then i take out the ethernet cord and put it into my other pc only to get limited or no connectivity, also my NIC card has no I/O range on the broken pc, but it has one on the working one,idk if that matters just putting it out there to give as much info as possible, i would reinstall but wouldnt it defeat the purpose since its been acting this way a new hard drive and fresh windows xp w/sp3 was installed

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?