My Nexus 7 No Longer Visible on my PC Windows Explorer

  RegScriv 16:04 17 Aug 2014

Suddenly, I cannot see my Nexus 7 in Windows Explorer when it is connected to my PC. I suspect it's something to do with the latest Windows update. I'm on Windows 8.1 Update and there was a big update a couple of days ago. It still works fine on my Windows 7 netbook. But when I connect it to my W8.1 PC, the PC indicates that the Nexus has been connected. It's visible in my system tray as connected and I can see it in System Devices. But I cannot see it in Windows Explorer. Can anyone help.

  Fruit Bat /\0/\ 17:57 17 Aug 2014

Your not alone (just tried mine) doesn't even show up in Calibre.

comes up in device manager as ACER ABD Interface

  Fruit Bat /\0/\ 18:05 17 Aug 2014

Ok got it

Click on ACER ABD Interface in device manager s

select update driver

select Browse My computer..

select let me pick from a list of devices...

it will then show ABD and MPT select MPT click OK

close and reopen explore and it should now show up. (mine does)

  RegScriv 18:47 17 Aug 2014

Well Done Fruit Bat!! Followed your instructions and I'm up & running. Many thanks.

  rdave13 19:58 17 Aug 2014

Hello Fruit Bat /\0/\ . It didn't work for me. Although it was going through the motions to installing MPT it reverted to ABD. Saw this thread and deleted the files in the C:\Windows\System32\DriverStore\FileRepository\androidwinusb.infamd64_ ....... (posted 16th January 2014, 09:41 AM by Loganberry ) and connected the Nexus and it works as the default ABD was not available.

  RegScriv 22:18 17 Aug 2014

Interestingly, Fruit Bat's solution worked for my mk2 Nexus 7 but it didn't work with my wife's mk 1. I wonder if I try your solution rdave13 will it cause the mk1 to work and the mk2 then not to work.

  Fruit Bat /\0/\ 15:33 18 Aug 2014

Mine's a mk 1 (2012)

  rdave13 16:19 18 Aug 2014

Mk 1 will post later on. On tiny phone at mo.Different driver on Asus site ABD for usb still not working but can have both

  rdave13 20:31 18 Aug 2014

Nexus 7 2012. Deleting the files and folder in the directory worked with the MPT usb drivers. All ok until windows update wanted to update Google acer ABD drivers and under heading of important. So I let it install and it failed. Not only that it knocked out the other drivers. So I uninstalled the Nexus in device manager, reconnected and installed MPT again. Got the Nexus working but the Win important update kept popping up. I know I can hide it but would rather have updates ok than using this fix to connect the Nexus. So I restored all files and folders to the directory and that kept window update happy. Unfortunately now I'll have to find another way for Windows to show the 7 in My PC.

  tullie 21:10 18 Aug 2014

Worked for me,thanks FB.

  RegScriv 10:26 19 Aug 2014

Not a happy situation rdave13. I used Macrium Reflect to take my PC back a couple of months. I then got both my mk1 and mk2 Nexus 7s back on line. Having seen that MS had supposedly pulled the August Update, I thought I'd be safe in letting Windows update, so I did. It knocked out both of my Nexus 7s again. Applying the driver updates separately through Device Manager got them both back again. (It appears they have different drivers).

MS has really fouled up the August Windows Update, supposedly meant to be Windows 8.1 Update2. MS are now recommending users to uninstall the August update.

Keep this up and I'll be moving to the hated Apple camp.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Book 2: Release date, price and specs

This First Man soundtrack vinyl cover art is exquisitely composed

How to watch Apple’s October 2018 iPad launch

Meilleurs VPN (2018)