My computer can't connect to DHCP

  TishTash 20:54 31 Dec 2005

I have a wireless connection to my BT Voyager 2091 Wireless ADSL Router on Windows XP Professional SP1, and everything was working fine until suddenly, my computer wouldn't connect. I later discovered that there was no default gateway because my computer was failing to connect to DHCP. I tried scanning for viruses, spyware and even got a tool that would repair files associated with TCP/IP connections but still no luck. Has anybody any idea what to do?

  Forum Editor 00:54 01 Jan 2006

is to download and install SP2 for Windows XP.

Then make sure that your TCP/IP settings are configured to 'obtain an IP address automatically'.

  TishTash 11:41 01 Jan 2006

I've done both of those, and it just comes up with "Limited or No Connectivity" now. XP tried to repair it but couldnt renew the IP address. :\ Thanks for reminding me about SP2 though, I forgot to reinstall it after my system crashed.

  Taran 13:22 01 Jan 2006

Click on Start.

Click on Run.

Type in this:


Now click OK or hit your Enter/Return key.

Type this at the command prompt:


Hit your Enter/Return key.

Now type in this:


Hit your Enter/Return key again.

If that reassigns a working address to the wireless card all well and good.

If not:

Switch your router off and then back on again (assuming it has an on/off switch).

Note, an on/off switch is NOT the same as a reset (sorry if that seems obvious but I'd hate to see you reset the router and potentially lose your ADSL altogether).

If it doesn't have an on/off switch see if it has a reboot/restart option in the router control panel.

Obviously I am assuming you can access the control panel via a standard network cable either using your laptop or another PC.

If wired DHCP is working and wireless is not we can start to narrow things down.

Post back with the results of the above.


  Forum Editor 13:31 01 Jan 2006

and then suddenly stopped is indicative of a problem with the ipconfig mentioned by Taran, so you should obviously work through his suggested fix.

The 'limited or no connectivity' message points to a Windows system error, rather than anything at the router end.

  TishTash 14:38 01 Jan 2006

These are the results of the ipconfig/release and ipconfig/renew:

Bad Command or file name
Bad Command or file name
Bad command or file name
Microsoft(R) Windows DOS
(C)Copyright Microsoft Corp 1990-2001.


Windows IP Configuration

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :


Windows IP Configuration

An error occurred while renewing interface Wireless Network Connection : unable
to contact your DHCP server. Request has timed out.


I've tried to connect with an ethernet cable but that doesn't work either. I know my wireless connection is fine, because the wireless card DOES connect to the router, just not the DHCP server for some obscure reason. I've also turned off and turned back on the router several times. This computer is connected to the router via USB and works fine so it's a problem with my computer itself. I've tried fixing winsock via the command line (netsh winsock reset) but it says it can't start the application because it cant find framedyn.dll. Maybe spyware or a virus has corrupted this file?

I know my wireless connection is fine because the signal strength is excellent (its only about 2m away from the router lol) but I'm so ANNOYED at the fact that it cant find the freakin' DHCP server. Do you think (since this PC connects to that same router) I could take the IP address, gateway etc from this computer and put it on the other one? :\ Or maybe I'm being a complete n00b. Meh.

  T0SH 15:20 01 Jan 2006

You can allocate a static IP address as say to your wireless network adaptor add your routers lan ip address for the default gateway and the primary dns server

Cheers HC

  Taran 16:12 01 Jan 2006

Follow my instructions as before to open up the Command Prompt window.

Once you're in there type this:


Hit your enter key.

Report back with the results.

Some people would have you believe that this verifies that your network adapter is working - it doesn't. It actually verifies whether or not your TCP/IP stack is initialising corrcetly.

As long as you get replies in a timly manner then we can move onto other possible causes.

It does seem like a local software issue given that a network connection cannot be established using cables.


  TishTash 18:00 01 Jan 2006

Wow... When I hit enter the DOS window just closed itself :S Yeah I think there's something wrong with the TCP/IP stack, but I cant fix it...

  Taran 18:08 01 Jan 2006

If your command prompt window closed itself without you clicking on the cross at the top right, or by typing exit the pressing your Enter key, then you have a problem with your PC software.

Since you admit that you did not update Windows after reinstalling it I am tempted to suspect something nasty at work - Windows updates are there to plug security holes and enhance functionality.

Going online for any length of time after installing Windows without applying all of the available updates will eventually result in the system becoming compromised.

Open up your Control Panel.

Double click on Administrative Tools.

Double click on Event Viewer.

Left click once in turn on each of the three listed items in the left hand panel.

Scroll through the resulting lists in the logs displayed in the right hand panel and look for any errors highlighted with an exclamation mark or a cross.

See if any of them relate to network settings, TCP/IP or similar and post back with the results.

I suspect you may have to get radical here.


  TishTash 18:36 01 Jan 2006

I made a notepad file of the errors and warnings I found:


The system detected an address conflict for IP address with the system having network hardware address 00:11:F5:B3:A7:04. Network operations on this system may be disrupted as a result.

For more information, see Help and Support Center at click here.



The IP address lease for the Network Card with network address 0020ED52186A has been denied by the DHCP server (The DHCP Server sent a DHCPNACK message).

For more information, see Help and Support Center at click here.

Your computer has automatically configured the IP address for the Network Card with network address 0020ED52186A. The IP address being used is

For more information, see Help and Support Center at click here.

These were just repeated. There was only ONE tcp/ip warning/error and that occurred on 30th december 05. The DHCP ones were quite frequent though... Ever since it stopped working to now.
Wait I just found the first one on the day it stopped working (occured at start-up time):

Your computer was not able to renew its address from the network (from the DHCP Server) for the Network Card with network address 0020ED52186A. The following error occurred:
The operation was canceled by the user. . Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.

For more information, see Help and Support Center at click here.

I didnt cancel anything -_-

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?