A multi-boot system fails to recognize USB printer

  cherm 15:04 04 Aug 2010

My pc is a multi-boot system, winxp pro, English win7 and Hebrew win7. My printer is an usb Brother mfc-5440cn. The printer served me all along while using XP and for a time, with my win7 installations.
Suddenly, I don't know why, none of the thre operating systems recognize my printer. I took the printer to a Brother service and it's in a working condition. I tried to install various drivers on each and every os, but to no avail.

What can cause thus strange behavior? How do I set the computer, each and every os, to acknowlege and use my printer?

  Jollyjohn 15:36 04 Aug 2010

Do other USB devices work? Check all the USB ports on the computer. It may be a fault with the PC.

  woodchip 16:03 04 Aug 2010

Remove all power from the PC also Battery if Laptop. Press and hold the On Switch for 15 seconds then retry the Printer after restarting pc

  cherm 07:30 05 Aug 2010

All other USB uses work as expected. I tried plugging the printer to various USB connectors, but the printer continued to be unnoticed.

  cherm 08:22 05 Aug 2010

Let me double check with you. Is the sequence you suggest as follows:
1. Shut down computer
2. Remove all power from the PC (it's a desktop, not a laptop)
3. Wait a while
4. Hold the switch for 15 seconds and then let the computer start.

If so, I did it, and the system still fails to recognize my printer.
If not, please clarify.

  cherm 08:24 05 Aug 2010

In 4 I meant "press and hold", not just "hold"

  woodchip 09:18 05 Aug 2010

Yes but you need to remove the 13amp plug also

  Jollyjohn 10:21 05 Aug 2010

Go to Control Panel, Device Manager and look for USB devices - is there a red cross on USB printing support?
If so right click on it and uninstall - reboot - plug printer in and it should be found.

  Simsy 10:33 06 Aug 2010

has failed on 3 operating systems on the same hardware suggests, to me, very strongly that it's a hardware, rather than software problem...

Which means either the USB sockets or the printer iself...

As it's more than one USB socket it suggests that if it's a USB fault, rather than a printer fault, then the USB problem is in the BIOS...

So summing up, I'd check the BIOS settings, and if all seems well there, check the printer in another machine.

Of course, I may be talking rubbish!


Good luck,



  woodchip 12:15 06 Aug 2010

Also it may just be a faulty USB cable or USB printer socket

  Paddylad 19:47 06 Aug 2010

I've no experience with a multi boot set up. My Lexmark 2350 was not recognised by my WXP last weekend. I tried various unplugging, using a different USB port etc and finally uninstalled it completely and reinstalled it. It's now working fine. Give it a try.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?