MSPaint fix needed

  [DELETED] 17:53 16 Nov 2003

I'm trying to get Paint to save as Jpg or Gif..( Reinstalled Win98 from backup)..

I tried the fixes from this site with no luck.
... : click here

[ I have a copy of the registry from another install -- can I import a specific branch from it to try to fix the problem ? and how if so. ]

  [DELETED] 22:37 16 Nov 2003


  woodchip 22:44 16 Nov 2003

If you have the windows disc, go to Add Remove choose windows setup click on accessaries and remove the tick in Paint then reboot computer and go through the same process to install but put a tick back in the box

  woodchip 22:45 16 Nov 2003

PS i Do not think it works with Jpeg or Gif

  beeuuem 23:22 16 Nov 2003

The Paint on my 98SE will only 'Save as' .bmp or .gif.
Unless you have a particular reason for using Paint you may find Irfanview is more flexible.
click here

  [DELETED] 04:58 17 Nov 2003

Hi Qmar
These instructions worked for me.
(Apologies to whoever wrote it. Lost the source)

If you already have the JPEG Graphics Filter on your system (and in both locations as stated above), but MS Paint still won't let you "Save As" JPG, you can manually edit the Registry to correct this. It's a simple fix. Go to Start, Run, type REGEDIT, and click OK. Go to this key by clicking the + signs beside the keys (folders):

HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Graphics Filters\Export\JPEG.

Click on the "JPEG" key (folder) in the left pane, and you'll see a String Value in the right pane with the name "Extensions". Make sure under the "Data" column it shows only "jpg". If it shows "jpg, jpeg", double-click on the "Extensions" string and from the "Value data" field remove "jpeg" so that it only reads "jpg" (without the quotes).

  [DELETED] 09:28 17 Nov 2003

saved to favourites-gday all -hol pol...

  beeuuem 12:17 17 Nov 2003

Well - I never knew that. Tried it and it works.

I'm well impressed, Thanks dcdc.

  [DELETED] 16:20 18 Nov 2003

I tried your registry tweak - by itself it didnt work for my particular setup-- but you pointed me in the right direction...I had a copy of my systems older registry.. from this I tranfered th whole of the 'shared tools - graphics' branch to my current unfriendly registry (I deleted the whole of the corrupted branch before doing this ).
Now it works. Thanks. (Windows98:userfriendly?-not).

I have uploaded the functioning registry branch here _ > click here

----..if interested to get to the uploaded file -- goto yahoo-uk&ireland ( click here ) sign in as pcadvisor84 and at the 2nd line type 'pcad777uk'... then browse to ...
my file at :click here

..... which is part of uk,f1,pg,briefcase,yahoo,com/bc/qmar777uk

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

16 illustration tips for packaging

Best external graphics cards (eGPUs) for Mac

Les meilleurs antivirus pour Mac (2018)