MsMpEng.exe is showing massive CPU usage

  Armchair 19:11 04 Feb 2011

when running certain programs, and is effectively crippling them. It's part of Microsoft Security Essentials, apparently. I don't really want to get rid of MSE, but if I can't find a solution to it's system hogging ways, it's going to have to go.

Ending MsMpEng.exe from Task Manager brings up a warning that MSE is no longer monitoring my system, and the exe starts again of it's own accord anyway.

I've tried opening MSE, going to the settings, and entering entering the relevant text to stop the exe from scanning itself (in Excluded files and locations, and Excluded processes), but to no avail.

Should I just lose MSE completely, do you think, and install something else?

  Armchair 19:25 04 Feb 2011

It's an old PC, but my spec. should be okay to run it (P4 2.66, 1GB DDR etc.).

  Armchair 20:14 04 Feb 2011

I'm using XP SP3.

It is the latest, updated version of MSE that i have installed.

I was using Avast prior to MSE, but there's no trace of Avast left on my system now.

  birdface 21:15 04 Feb 2011

Go into services and if Windows Defender is set to automatic .Turn it off.

  Armchair 21:17 04 Feb 2011

You couldn't walk me through the necessery steps to do that, could you, buteman?

  Armchair 21:22 04 Feb 2011

Ah, got it.........

Windows defender isn't listed in either column (Extended or Standard), though. Microsoft Antimalware Service is listed in both of them, though.

  birdface 21:50 04 Feb 2011

Picked that up from here.
So not 100% sure if that is any help or not.

click here

It would be control panel.Administration tools.Services. Then scroll down to Windows defender.

  Armchair 09:46 05 Feb 2011

Thanks. I can disable the AntiMalWare Service, which stops MsMpEng.exe, and (seems to, anyway! I'll test it a bit more today) so allows the relevant programs to run without slowdown/glitches, but doing so turns off MSE (so my system has no protection). MSE restarts when I reboot my PC.

I think I'll compromise for now. I'll keep MSE, but go offline and disable the AntiMalWare Service when I want to use the programs (which don't require me to be online, anyway). Not ideal.

  birdface 09:49 05 Feb 2011

Maybe best bet would be to remove MSE completely then reinstall it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?