MP3 player not recognised

  Pineman100 09:31 23 Feb 2010

I run Windows 7 Home Premium. My MP3 player is a Sandisk Sansa.

Normally, to charge the Sansa, I just plug it into a USB port on the computer. It is immediately recognised and charging begins.

Today while I was out walking the dog, the Sansa ran out of juice. So when I got home I plugged it into the computer in the usual way. The computer didn't seem to know that it existed. It didn't start charging, it didn't show up as a drive in Windows Explorer.

I restarted the computer with the Sansa plugged in. No improvement. I ran "Scan for hardware changes" on the USB entry in Device Manager. No change.

I tried the Sansa in my wife's Vista computer (which has also charged it from time to time). Same result - the computer didn't recognise the Sansa.

Any ideas, please?

  canarieslover 09:47 23 Feb 2010

I have found with other MP3 players that if the battery is allowed to get to the stage of totally empty it may need to be plugged in for quite a long time before it starts to pick up a charge again. My son is the worst culprit for this as he often takes off the headphones and leaves the player going. I have a standalone USB charger and often leave his player on charge overnight and still sometimes get no response from it. I have also resorted to unplugging fromm charger every 10 minutes and then plugging it back in until it finally gets recognised and starts chargeing normally.

  Graphicool1 11:13 23 Feb 2010

Check the Device Manager
1. Right-click My Computer, and select -- > Manage.

Click Device Manager on the left pane.
NOTE: Sansa MP3 Players can connect to your computer in MSC or MTP mode.
MTP mode is the recommended and default method for Sansa Players when used with Windows OS.

The Sansa player will show up on Device Manager's right pane as:
1. USB Mass Storage device (if the player is set to MSC)
2. Portable Device (if the player is set to MTP mode)

If there is a yellow exclamation point (!) or question mark (?) beside the device, try to refresh the drivers.
Refresh the drivers
1. Right-click the entry with the error mark, select Uninstall.
2. On the top menu, click Action then select Scan for hardware changes.

NOTE: If a device with yellow exclamation point (!) continually appears and disappears, then the player is most likely failed. Additional troubleshooting is unlikely to correct the problem.
>>>> BUT TRY THIS <<<<<<<
Connect using MSC mode
Connecting in MSC mode will help determine if there is a problem with MTP mode or with the Auto Detect mode feature of the player. You can use Forced MSC mode or switch the player settings to MSC.
Verifying and changing the USB mode of the device to MSC or MTP From the Main Menu, select Settings > USB Mode.

  Woolwell 12:15 23 Feb 2010

I've got a Sansa Clip which was totally unresponsive a week ago. I did a reset on it and has worked fine since then. Whether this will work with a completely flat battery I don't know?

  Pineman100 15:42 23 Feb 2010

for your thoughts and ideas. Here are my responses:-

canarieslover: OK, I've been trying that solution for a while now. No response yet, but I'll keep trying.

Graphicool1: I followed your instructions, and I found two drives listed in Device Manager under Portable Device (which suggests that my Sansa is in MTP mode). The existence of two drives is understandable because my Sansa has a micro-SD card plugged into it. But neither of them had an exclamation mark against it.

In both cases I still tried Scan for Hardware Changes, and the computer tried to find the drivers, without success. Oddly, in both cases it then asked me whether I wanted Windows to download the drivers for my infrared device! I replied no - was that the right thing to do?

I note your suggestion about changing to MSC mode, but in order to do that, the Sansa must be functioning, and it has a flat battery.

Woolwell: Please could you tell me how you did a reset on your Sansa clip? Mine is a Sansa e260, but I presume the function will be similar.

  Woolwell 16:00 23 Feb 2010

See click here but I doubt that this will work without any power.

  Woolwell 16:02 23 Feb 2010

See click here and you can change the battery.

  Pineman100 17:44 23 Feb 2010

And today's major award goes to....Woolwell!

Resetting worked! The Sansa came to life, and the computer immediately recognised it. And it's now happily charging!

Huge thanks, Woolwell, and to everyone who's contributed their ideas. Very much appreciated.

  Woolwell 23:08 23 Feb 2010

Glad it's sorted. Strangely my Sansa Clip stopped on a dog walk too.

  Graphicool1 10:29 24 Feb 2010

All's well that ends well ¦¬) G1

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique