Mozilla firefox not working

  kimtrnc 05:16 10 Nov 2009

Turned my system on this morning - tried to fire up Mozilla Firefox. System says "another instance of Firefox is already running" - far as I know there ISN'T!
Tried several restarts, as advised..nothing. I COULD uninstall and re-download, but then I will lose all my bookmarks, won't I? (No, of course I haven't backed them up lately, wouldn't you know it!)
Whole system is poorly at present, likely, I think to Microsoft's **** Frameworks, which are causing other problems.
Anyone help me,please?

  ambra4 05:43 10 Nov 2009

Just uninstall and reinstall firefox

  kimtrnc 05:57 10 Nov 2009

done that - several times. Still getting same message. I tell you, I can't wait to get a new Win7 machine - this one is getting weirder and weirder - even system restore is doing strange things...

  Bob The Blob 06:23 10 Nov 2009

Reinstall your operating system then. It'll be back to new.

  kimtrnc 08:07 10 Nov 2009

Hi Bob - can I reinstall OS without losing all my progs, then? Do you think it is the OS at fault, rather than Firefox?

  Hillwood 08:39 10 Nov 2009

AdBlock Plus add on latest version is causing similar problems to your own for many users. If you have this add on I suggest you uninstall until it is fixed.

  Bob The Blob 12:19 10 Nov 2009

...Whole system is poorly at present...
...this one is getting weirder and weirder - even system restore is doing strange things...
and Firefox playing up too.

If that was my system I would definitely go for a fresh install of the OS and start from scratch.

  rdave13 12:28 10 Nov 2009

Open task manager and see how many firefox.exe processes are running. End the processes and try opening FF again.

  kimtrnc 13:53 10 Nov 2009

rdave, that is the point - there AREN'T any firefoxes running at all, unless the name has suddenly changed.

I have now reinstalled and uninstalled several times. Sometimes Firefox reinstalls and seems to be working okay, but as soon as i log off, same thing: "another instance of Firefox is running", when, according to Task Manager, it isn't.

Also tried earlier versions of FF: same thing.
Think a new computer beckons...

Thanks everyone for attempts to help

  User-1229748 14:27 10 Nov 2009

do you have adblock plus add on like hillwood advised if so uninstall adblock before uninstalling firefox then try.apologies if you have tried this.on my dads pc he had a problem with spywareblaster also.

  User-1229748 14:29 10 Nov 2009

actually as i recall i uninstalled no-script aswell.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)