mouse not working

  bigrad 22:40 29 Jan 2010

The Logica USB mouse on my laptop has suddenly stopped working. The USB ports themselves are all fine and device manager says all is well and the drivers are reported as up to date. There are no power management issues for the USB ports. The mouse itself works fine when used on my PC, so the fault must be on the laptop somewhere rather than the mouse. I have checked as much as I can think of but have run out of ideas. The mouse however is clearly not being detected. Any advice would be appreciated.

  Sea Urchin 22:42 29 Jan 2010

Does the touchpad work OK?

  bigrad 22:44 29 Jan 2010

Sorry forgot that. Yep the TP works fine.

  Sea Urchin 00:08 30 Jan 2010

You didn't mention the make or model of laptop - but in general terms try going via Control Panel into the Mouse settings (or maybe Synaptics folder if that's what you use). It is often possible to arrange for the mouse to be disabled while the touchpad is being used (and vice versa). Have a look at the various settings for a clue.

  john810 02:40 30 Jan 2010

<a href="click here">iPhone Ringtone Maker</a> is a powerful iPhone Ringtones Maker which can not only convert mainstream audio files like WMA, WAV, RA, M4A, MP3 to iPhone ringtones in M4R format but also make iPhone ringtones from videos like AVI, MPEG, WMV, DivX, MP4, H.264/AVC, AVCHD, MKV, etc.
<a href="click here">iPhone Video Recorder</a>

  bigrad 09:04 30 Jan 2010

I have checked the mouse properties box but only the synaptics PS2 touchpad is enabled in device settings. No other devices are listed, which presumably they should be. However the mouse is plug and play and is listed under the devices tab and is showing as working normally, which clearly it isnt. I do not know if the mouse was ever showing in the device settings tab but it seems logical to assume it was and now its not is the reason its not working. Since the mouse works fine on my PC I guess I just need to force the laptop to recognise the mouse. I have tried to get the system to recognise the device but it just says no devices installed and doesnt recognise the mouse, despite it being listed in device manager as working normally. The driver is up to date and device manager has it listed as worked normally but clearly its not. Any ideas?

  Sea Urchin 12:07 30 Jan 2010

Try removing the mouse and then disabling the touchpad - there should be a key combination to do that - and then replug your mouse and see if it responds.

Also, does your mouse have a driver disk? It might need to be reinstalled.

  bigrad 12:36 30 Jan 2010

I thought about disabling the touch pad but didnt want to risk it in case I was left with no mouse and no touch pad. What I did in the end was disconnect ALL USB peripherals, reboot, reconnect everything and reboot again. Suddenly everything kicked into life again apart from one USB socket in which the mouse wont work while connected to but for which all the other peripherals function perfectly. Bizarre, but I dont care why it worked only that it did. Just as well as the mouse didnt come with a disk and synaptics website wasnt much help. The mouse properties box has now reidentified my mouse and all appears to be well apart from the odd behaviour of just the one USB socket when the mouse is connected to it.Cheers for advice and help.

  Sea Urchin 12:43 30 Jan 2010

Glad to hear it's sorted.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?