Mouse dead after driver update

  Throbber 17:02 21 Dec 2008
Locked

I was happily updating some drivers when, after reboot, my mouse won't work. I get to the screen "to begin, click your user name" but can't get any further, as no mouse. Any idea how I can get it working again? Probably by roll back, but how do I get there without a working mouse?

  Throbber 17:03 21 Dec 2008

Sorry, should have added wndows XP pro, SP3 and USB mouse.

  Technotiger 17:25 21 Dec 2008

Try it in Safe Mode.

  Throbber 17:36 21 Dec 2008

How do I get to safe mode? Pressing F8 during startup gives screen "Select a boot first device"
Hard Disk
-Ch2 m. Hitachi HDT725032VLA36
- Bootable Add-in cards
CDROM

  Technotiger 18:04 21 Dec 2008

Can you select your hard drive by using the up/down arrow keys and pressing Return.

  Throbber 18:15 21 Dec 2008

Yes, tried this [on all 3 options] but still couldn't get to safe mode pressing F8. I may just re-install windows, as the current install is only a few days old following a hard disk failure, so I won't lose a huge amount of stuff.

  Technotiger 18:21 21 Dec 2008

Fair enough, that does seem the best option under the circumstances. Good luck.

  BRYNIT 18:36 21 Dec 2008

May be a silly question but have you tried removing the USB mouse and plugging back in.

  Throbber 19:24 21 Dec 2008

Thanks Guys. BRYNIT - I had tried unplugging & plugging. Have now re-installed windows, and all seems well.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)