motherboard is not giving power to fan

  ardv 14:27 23 May 2019
Locked
Answered

Hello, I have a condor laptop (nomad n14) with this mother board: “hannstar j 94v-0 e89382”, which has the fan stopped working, I get the fan off the motherboard and it worked fine, so I tried to measure the voltage that the motherboard is giving to the fan and I found that it is null (0 v), I searched the net and I found that this may be caused due to bios problem, so I removed the battery and the CMOS battery and clicked on the power button about 15 secs, and then putted the battery again, when I enter F2 options I find that the time has changed (I suppose that the bios is reseted, but the laptop did not take too much time to boot up, I red that it should take some time to boot up after BIOS reset, and the options in the F2 menu does not have bios reset option), but the fan is still not working, I tried to power the fan from the USB output, when I put both 5v and gnd from USB port it does not work, but when I put just the 5V from the USB port and the gnd from the normal fan motherboard connectors the fan works, but the Hard disk stops. I hope that you can help.

  ardv 04:40 24 May 2019

Edit: I tried powering the fan from a phone charger with 5V, when I monitor the CPU voltage with speccy it seems that is good ( average 36°, but when not powering the fan the temperature keep rising until the laptop shutdown), but after few minutes the laptop keep beeping -discontinuous beep- for a while and then the it shuts down. i think that the computer shuts down because it does not have the signal that the fan is working, i tried to wire the 3rd wire of then fan in the motherboard like it was but nothing changes (i think i should also wire the gnd so as the 3rd wire signal works? but the gnd now is with the external charger), or may be this is caused from another thing. the other problem that the fan now is making lot of noise (i think normally the computer regulates the power of the fan regards the temperature).

  Fruit Bat /\0/\ 08:35 24 May 2019

you probably need to reset the BIOS by using a dip switch / jumper (usually a dip switch on a laptop) your manual should tell you where it is

  ardv 11:38 24 May 2019

"you probably need to reset the BIOS by using a dip switch / jumper (usually a dip switch on a laptop) your manual should tell you where it is" i couldn't find the jumper on the board, and i also couldn't find the board manual.

  ardv 05:22 02 Jun 2019
Answer

Problem Solved!

this program: "SpeedFan" solved it. when i launch the program and then choose 'automatic fan speed' the fan starts working (i've wired the fan in it's original place in the motherboard), i first tried it several times, and then even when i close the program the fan will still work, i tested the laptop for several hours and it's working well! i think that the problem was in the BIOS, and when the fan return working again with that program, the BIOS programs deals with the fan normally.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Qualcomm commits to cheaper connected laptops with Snapdragon 7c & 8c

Artists fight back against bots stealing their work to sell

Best Apple tech gifts for Christmas 2019

Les meilleures tablettes tactiles pas chères (2019)